GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Display type won't keep


#1

Hi,

I created a Lister Style for viewing thumbnails. I have no default folder set for this style, so it opens the most recent folder. I have it set to display thumbnails, yet if I navigate to a different folder (even navigate to subfolders), the display switches back to “Details” mode.

Do I have a setting somewhere that defines “Details” as some global setting that is screwing this up? I’ve looked everywhere and don’t see what the problem could be. I’d like it to keep Thumbnail mode for everything while viewing the lister type I created for this purpose.

Thanks!


#2

[EDIT]

I should add that once I select “Thumbnails” from the “View” menu, every folder I view keeps the Thumbnail view mode… however, this is an unnecessary step I’d rather not take every time I use this Lister Style.


#3

You could also try the Format Lock, available from the standard status bar. It will also lock the currently selected content type. (I’m not sure it saves with the folder format, though, you’ll need to try it.)

[quote=“ashoka”][EDIT]

I should add that once I select “Thumbnails” from the “View” menu, every folder I view keeps the Thumbnail view mode… however, this is an unnecessary step I’d rather not take every time I use this Lister Style.[/quote]


#4

Turn off Settings, Preferences, Folders, Options, Enable Folder Content Type detection since this will change formats automatically
when certain types of files are detected and is often the source of confusion.

See this FAQ posted by Nudel:
[url]Folder Formats: Quick Guide]


#5

Enable Format Lock inside your Lister Style.


#6

[quote=“Christiaan”]Turn off Settings, Preferences, Folders, Options, Enable Folder Content Type detection since this will change formats automatically
when certain types of files are detected and is often the source of confusion.

See this FAQ posted by Nudel:
[url]Folder Formats: Quick Guide][/quote]

That option was already turned off.

-Mike


#7

The Folder Formats and View Modes stored inside of a Lister Style generally only apply to the folder first listed when the Style is applied, unless the style enables the Format Lock. Otherwise, upon a folder change, uses the Folder Formats system to format the file display listing. Opus will go through an order of precedence (top down in the Folder Formats Dialog) and use the first: Folder Format, Content Type Format, or Default Format that is applicable to the listed folder (and enabled). If nothing else can be applied to the listed folder, ultimately Opus will use the Custom Default Format, which cannot be disabled.


#8

You know, I am still amazed at the power Opus gives its users. It is truly “old school” in the best conceivable sense of the word.

And what really gives me shivers sometimes is the thinking about the fact that it’s still an untainted dream of just two guys who insist on creating the best software they possibly can—and have the guts not to give in to the pressures of “business” or the temptation of easy-to-rake green pa$ture$ marked by useless “upgrades” and crappy adware-bloated new releases.

Sorry for the offtopic reply, I will keep my mouth shut here from now unless I have something specific to contribute.


#9

Hi,

I totally forgot about posting this message here - I’ve tried all your suggestions, but nothing works. Here is my scenario:

I have one lister style “Thumbnail Gallery” which is single pane, folder tree, thumbnail display. The background is gray in color.

I have another one called “TV Download” that is dual pane, details mode.

If I click on “Thumbnail Gallery”, I get the proper format as set up in preferences. However, if I click on the “TV Download” lister tab, instead of details, it is the same format as the “Thumbnail Gallery” tab - gray and thumbnails. If I click again on “Thumbnail Gallery”, it goes back to details, but the background is still gray and not the system default. Only if I navigate out of the default folder for the left pane (either by entering a subfolder or from tree) does the proper background appear.

Thanks again for helping.


#10

You need to edit the “TV Download” style in Preferences and set it to change the display mode.

If a style isn’t set to change a display mode then the current mode will continue to be used.


#11

Thanks for your help - I finally got everything here worked out, but I have a couple more questions.

  1. Is it possible to save column widths? Each time I reset any lister style, the column widths are reset, I like to keep the filename column wide since I deal with a lot of files with long filenames.

  2. The filename filter - I head this can be applied in realtime (as you type) instead of hitting ‘enter’ to apply the filter. How would I go about this?

  3. Can I save the size of the entire window? I have a huge desktop, and I hate wasting it all by keeping programs maximized - if I un-maximize Opus, it never keeps this saved window size, and reverts back to a tiny 512x384 (or thereabouts) window size.

Thanks again!

-Mike


#12

There’s a Width column on the Columns tab of the Folder Options dialog. Make sure that the Auto-size columns option on the Display tab is off, too.

There’s a FAQ which covers the filter.

I think the easiest way is to set the window size as you want it and then use Settings -> Set as Default Lister to tell Opus to remember the size. (If this doesn’t work let us know how you are opening your lister(s).)