GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DO 12 - Rename Function No Longer Works


#1

Greetings,
I recently upgraded to DO 12 and my Rename Function no longer works. Here is what I had assigned to an icon on my Apps toolbar:

Label: Rename Photos
Hotkey: [blank]
Function: Rename ....(.+) \1

This renamed a number of selected JPG files from (for example) DSCN7450.JPG to 7450.JPG
In other words, it stripped the first four characters from the JPG file that the camera created.

I get no error message when I try to run this in DO 12. It just does nothing.

Help would be much appreciated.


#2

The command syntax there is incorrect. I'm not sure why it would ever have worked.

Please link your account and we can tell you the proper syntax.


#3

Hi Leo,
Thanks for the very quick response.
Uhh, how do I link my account?


#4

There should be a link at the top of your posts saying "please link your account for priority support".

Alternatively, go here: https://resource.dopus.com/link-opus


#5

OK, I think that's done.


#6

Many thanks!

Here's the command for placing in a button or hotkey:

Rename REGEXP PATTERN ....(.+) TO \1 IGNOREEXT

Alternatively, if you want to create a Rename Preset, it would look like this in the Rename dialog:

If you're using the default Opus 12 toolbars then any presets you save will appear in the Rename menu automatically, with any favorited ones at the top. You can also make buttons which run a specific preset with a command like this:

Rename PRESET="My Preset Name"

That would do the same as the first command in my post, but let you have access to the same thing in the Rename dialog, with both the button and Rename Preset tied to the same definition, if that is useful to you.


#7

Thanks a heap, Leo. This worked like a charm!

Rename REGEXP PATTERN ....(.+) TO \1 IGNOREEXT

:+1: