DO 9 UAC question

Well been playing around with Opus 9 and just about got everything set up how I want, it’s a great new version. Just two things I'm having problems with at the moment.

  1. Double click on desktop brings up the lister in different locations depending where I double click. How can I set it so it always comes up in the position I set it to when I save the default lister? Double clicking the opus system tray icon always opens in the correct location.

  2. Running on Windows Vista under a standard user account. Running Opus I am unable to create folders in the Program Files directory. When I try and create a folder I get the UAC prompt to enter my admin account and password which I do but then I get a box that pops up telling me an error occurred creating folder (see attachment). I then went into Windows Explorer and tried to create a folder and it works ok. Any ideas?

To make desktop double-click ignore where the mouse is I think you need to set it to open a saved layout instead of the Default Lister. You can do this via Preferences - Launching Opus - From the Desktop.

Also note the new "open layout relative to the monitor the mouse is currently on" checkbox that each layout has under Prefs - Listers - Layouts.

I'll see if I can reproduce this in a moment. Does UAC work okay for you with an admin account?

Hi nudel,

Yes, if I login as the administrator and create a folder in program files from within DO9 it works ok.

While I was logged into the administratrs account I created a folder on a spare hard drive and altered the permission so that SYSTEM and the administrators group had full control and the users group just had read access. I then logged back into the standard users account and tried to create a folder in this account and I get the same problem, so it seems it’s not just some setting in the program files folder. So at the moment I am unable to carry out any admin tasks in opus, I have to load up windows explorer to do it.

I’ve just put DO in administrator mode and I see the word administrator on the title bar but I still get the same problem when trying to create a folder in program files. Could it be because my administrator user account is called admin and not administrator?

I can confirm the problem with UAC and non-admin accounts. I've raised a bug report so it'll get fixed.

Thanks for the confirmation nudel, I won't waste any more time on it now.

Sorry about this! The installer was missing a crucial registry entry for non-admin UAC access.

We'll fix this today but in the mean time you can use the attached .reg file to solve this problem. (368 Bytes)

This has been fixed now. If you experienced the problem, please download the minor update. More details here:

[Directory Opus 9 now available!)

I’ve downloaded the new version and installed it but I still couldn’t carry out admin tasks. So I went back and downloaded the reg key that Jon provided and this has fixed the problem  I’m just wondering why the new version that I downloaded didn’t fix the problem. Is there any way for me to find out if I am using the new version of DO9 or the original version? Maybe it didn’t install correctly, I’d prefer to be using the newer version in case I run into any other of the bugs that the newer version fixed. Cheers.

Maybe your browser had the installer cached and didn't notice the new one?

The current latest installer is:

13,781,096 bytes
MD5: f77240a8ecff78f1dd6c932a513cfab2

How can I check the MD5? I've added the MD5 Checksum column but it says next to the dopus file.

Also is there anyway to actually check what version i'm currently running? Maybe by checking the actual dopus exe file?

Select the file and run GetSizes NODESELECT MD5 which I think ignores the max size.

I think the versions are in the version resources of the files but I don't know which version's which. (I'm actually still on the first 9.0 release as I haven't needed to update since.)

That did the trick, the checksums match so I have downloaded the correct latest file. Not sure why it didn't fix the UAC problem. Guess it doesn't really matter because the reg fix sorted the problem out. Will just wait for the next update which will have the fixes in anyway. Thanks