DO very slow at copying/moving files

My typical past speed when copying a file from my PC to NAS using DO was around 30+ Mbps. From a couple of weeks - without any apparent reason - it has dropped to 7-8 Mbps. At the same time TeraCopy I also use can reach 80 Mbps.

I strongly prefer DO's copying feature (it's great when it comes to warning of overwrites), but the speed makes me mad. Anything I could do to improve it?

Something must have changed between now and then. The way Opus copies files hasn't changed.

Maybe your anitivirus on the client or server?

I don't think so... Sure the AV version has upgraded (but only in the minor nor major way), the NAS OS got upgraded, but that's it.

In fact DO happens to regain the old speed randomly yet unfortunately rarely. There are also no other substantial file operations that might limit the read/write speeds...

The NAS OS being updated is a potential cause for the change for sure.

Is there anything I can do myself or do I just need to keep observing and use TeraCopy whenever the faster transfer needed?

It's hard to say without knowing why the NAS / network or whatever the bottleneck is has become slow.

Changing the copy buffer size can sometimes help with things that don't like a particular buffer size for some reason. (Preferences / Miscellaneous / Advanced [Filesystem]: copy_buffer_size. Try 2 MB for example.)

Thank you, Leo!

It looks this did the trick and my DO native copy speeds are now up to 100 Mbps, so TeraCopy has been officially beaten! :wink: