DO11: Reading Rar not working

The solutions are already above.

11.1 Beta 3 also has a newer unrar.dll which may help, but if not just change the setting mentioned above to use 7z.dll instead.

Hi again,

I'm on Beta 3 now. Unfortunately the error when using unrar.dll is still there.
So I did the change in settings about the use of 7z.dll and it works... but that left me with no RAR5 support.
Its not a big deal because I don't use it (not right now, but maybe in a near future).
But I hope this is just a temporal solution, because this issue is not totally fixed.

Kind regards.

Can confirm 11.1 beta 3 still has the problem.


The change in preferences solved it.


Anyone able to generate a ProcMon log for this? (Please include all processes, not just dopus.exe)

Tried to do this and spent quite some time on it. In my case Procman records roughly 250 entries per second... but sometimes close to 700.
It is a bit complicated to exactly capture the entries involved.
Between extract rar and abort action is about 2-3 seconds.
I'll send you the excelsheet, fwiw ..


A PML log is often more revealing than what it writes to the Excel versions. They should zip up quite small even if the input is large.

ah well, okay.
you may wish to check yr mail.

Nothing's come through to, if that's the one. (Only .net address I have.)

Hi Leo,

I sent you my log via email.
Tell me if you got it.

Thanks for all

TrAnS: Got it, thanks!

I think we've found the cause of this now, thanks to the logs that TrAnS sent me.

The fix should be in the next beta version, 11.4.1. (We'll be releasing 11.4 before then, which will not contain the fix. Shortly after that, we'll release a beta with some newer changes.)

Out of interest, for those who were experiencing problems, have you turned on NtfsDisable8dot3NameCreation in Windows? Or done anything unusual to your Program Files folders, like used a junction/softlink to re-point it to another drive?

Well, we're up to 11.6 and I still have the problem. I've made none of the changes listed in the previous post by Leo or anything along that line. I've gone as far as trying other unrar64.dll files but no luck. This has become a real pain considering there isn't anything wrong with the RAR files and WinRAR handles them just fine. I gave up on anyone fixing this problem so I chose to remove RAR under Preferences\Zip & Other Archives\Archive and VSF Plugins and let DOpus open WinRAR instead. Not as convenient but I don't want to be bothered having DOpus open some RAR files and not others, so I'll just stick with this for now.