Do12.1 Tags not showing in column

After having Dopus open for along time Tags and Commets columns no longer show anything (Folders and Files), neither does tool tip info, if I open the metadata panel the info for Tags and Comments is shown.
Is there anyway to get Dopus to reshow the Tags and Comments without fully exiting and restarting Dopus. I have tries F5 and GO REFRESH.
This is happening on Fixed and USB Hard Drives

Does closing the window and opening a new one fix things, or do you need to exit the whole program?

Have the info tips been edited to include the shell info tip, or details from individual shell extensions? It's possible something is causing the thread which gets the info tip data to hang, which would usually be caused by a shell extension going wrong.

Only Exiting the whole program

All Files
Type: {type}
Date Modified: {modifieddate}
Size: {sizeauto}
MD5 {md5sum}

All Files and Folders
No Info tip

All Folders

Have only added {keywords} to All Folders in the last few weeks not sure when Tags and Comments stopped showing

It might be worth removing {keywords} to check if it is involved.

The next time Opus is in a state where the infotips are not showing, please do this:

[ul][li]Open Task Manager and click on its Details tab.[/li]
[li]Find dopus.exe and right-click it.[/li]
[li]Select Create dump file. (It should then tell you where the file has been created.)[/li]
[li]Zip the dump file and email it to[/li][/ul]

We may then be able to look at the dump file and see if the infotips thread is hanging or waiting for something, which may reveal more.


Have removed {keywords} and still happening

Have sent email for dopus.dmp

As a quick test, please try disabling the Movie plugin (Preferences / Viewer / Plugins) and see if that stops it happening.

The call stack suggests the file-info thread may be hung waiting for Windows to extract information about an AVI video file:


Tried to reply yesterday but could not get on the forum.
Could not try the first part as I had already found the culprit.
What you found is correct it was an AVI but I did not know this before I did my testing.
Yesterday afternoon I spent some time trying to find out what was happening as it was happening a lot.
I traced it to a folder on my NAS drive that I use for putting files in before moving to other machines.
Each time I went into the folder then to a folder with Tags they had disappeared.
I decided to move all the files out of the folder into a new one.
They all moved except one which the system said was in use by another process.
If I went into the new folder and then to a folder with tags they all showed as well as infotips {keywords}.
If I went into the folder with the undeletable file the tags disappear.
Have powered down the NAS and restarted but I cannot delete the file.
Thinking about it now when I use TV and browse to NAS drive some of the folders were missing.
Now I have renamed the folder with the faulty file to zDoNotUse which puts it at the bottom on the folders I can see all the folders, but files in the root are not shown.

Will have to find out how to delete a file on a NAS drive.

I have found the answer use File Explorer (go wash your mouth out) Dopus would not delete the file but File Explorer did.
Not sure why I thought a second rate program could do something that Dopus could not do. :frowning:
When I first tried to delete the file with File Explorer it said that Dopus had it open, Dopus was in the folder with the file should have moved away from he NAS and tried again, but I completely closed Dopus and File Explorer then deleted the file.
It looks like Dopus was stopping me from deleting the file.


Thanks a lot for looking through the dopus.dmp
As usual great support from the Dopus team
Keep up the good work on a great program.

That makes sense.

Is was the dopus.exe process that had it open, but only because the Windows API for opening AVI files had got into an endless loop and was never going to close the file.

Unfortunately, code that works with video data is still a bit like printers: No matter how much we progress, it never quite works properly. :slight_smile:

In the long term, we have some ideas about how to make Opus more robust in the face of these problems. (We can't easily solve the problems themselves, as they're usually in someone else's code/components. Opus itself doesn't process video data, it only talks to other installed components which advertise their services to other software via the registry.)