GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DO12 - Adding tags changes created date

[quote="leo"]Please give full details:

[list][*]How are you changing the tags? (Via the metadata panel, or via a command? If it's the metadata panel, is it from a lister, the viewer, or standalone? If it is a command, what's the full command?)[/quote]

It's like here. The green box shows the original created time of the image. The red box shows the second step, adding some keywords, which are called Tags here. When i save the changes, by clicking, or by moving to the previous or next image, the time in the green box will be updated to the current time. I see this happening with JPG files so far. As for the metadata settings, all three checkboxes are checked. But i didn't change this recently.

Thanks for the extra details!

I think I am doing the same thing, but so far only the Modified timestamp changes for me, which is to be expected (if it's set to be changed in Preferences, of course).

The files you're changing: Are they on a local HDD, or something more exotic, e.g. network share, inside an archive, or anything like that?

Just in case it's something specific to the JPG files you're modifying, here's a test JPG (screenshot of Opus). Could you right-click and download it, then see if the same timestamp problem happens if you modify it?


Many thanks.

No, the time stamp is not modified with your image. Strange. I tested several examples, using different cameras, Olympus, Samsung, Fuji, but they all change the created date. I tested your file in one of the locations where it happens, just in case.

But i found another interesting thing. If i paste an own jpg screenshot anywhere, it behaves just like yours, no changed time stamp. If i convert an image, decreasing the size under ~1MB (didn't test it more precisely), the time stamp is stable. The same image, with less compression & a file of more than 1 MB, the time stamp changes again! So, i guess, it depends on the file size.

The problem still persists in 12.09.

Unless the release notes say something is fixed, and you find it still happens, you can assume it hasn't yet been fixed but remains on the list. No need to bump the thread.

Ok, thanks. Quite often i see the announcement, that the bug was acknowledged, & will be fixed soon. Sorry then, but i wasn't sure, if you finally could reproduce the effect.

I can't reproduce this either. Can you post an image that it happens on?

Here is one image:
P4090.zip (5.06 MB)

We can't reproduce this problem with your image either, unfortunately.

Are you sure you're not accidentally changing the creation date field yourself? When you edit the tags the field overlaps the date field (since you have so many tags in there) so is it conceivable you could be accidentally clicking something on the date field which causes it to change?

Well, i think i can rule that out, because it happens to all images, where tags are added. I will investigate further, if maybe some other cause be responsible. Meanwhile, i will keep running SetAttr META createdate:datetaken over all processed images.

My workflow also includes denoising, & adding geo data, using some third party tool (Geosetter), which don't touch the created dates, but using Lightroom does (i run above command to set ist back), so maybe LR triggers some properties, which make the created date "fall back" to the erroneous behavior, whenever tag editing is involved.

I did not mention this detail, because i assumed, it would be some separate issue. By the way, i couldn't spot any setting in LR, which may cause this. But i doubt, that it is the reason, because the tag thing also happens with images, which were not processed through Lightroom. Thanks a lot, & if i find something new, i will report it here.

No changes until 12.14, could you PLEASE further investigate! It has to be Opus. If i give rating stars, the date changes to the current time, also, when i add tags or keywords, or whatever they are called (like "trees", "boats", "people", etc.)

Which other function else could trigger it? How can i compare, if it also happens in Explorer (i don't no way to add tags, or rating there). Like i said, it didn't happen in the tiny image you gave me, but with larger images around 5-10MB. It used to work in version 11, so there must be some reason, why it is broken. This is a beta test, right? So maybe some other users would care to run a short test on their images, if they also can see this bug happening. It is not acceptable to leave it like that! & sorry for bumping, but i expect bugs like this to be investigated & get fixed eventually.

What are the exact steps that you're doing when you see it happen?

Are you seeing this happen when running only one, single-line Opus command (or Metadata panel action) on the files? (What is the exact, full command/action?)

Or is it only happening with a more complex workflow involving multiple steps/commands or even external programs?

The same thing here. Adding a new tag using the metadata panel changes Date created for every JPG I tried. Date modified only changes if the corresponding setting in preferences was set. A german problem?

For example, i have that image, which was taken this afternoon at 18:32, but when i run the command SETATTR META rating:5 on it, using the shortcut, or, as you suggested, directly in the command line, it will change the date the current time, like 23:59.

The same thing happens, when i open the new meta data editor, & add tags / keywords in the field. Talking about my workflow, if i run some external, standalone noise removal tool on the files, the date remains stable. The same, if i manually add GPS positions using Geosetter, the created dates will be fine. Here is roughly my current workflow:

  1. selecting files as outtakes, moving them to another folder Ok
  2. normally here, all images receive one "counting" rating star dates change to current time
  3. minor tweaks on all remaining images done in Lightroom Ok
  4. de-noising w. Nikcolor Ok
  5. going through the images, adding tags/descriptions dates change to current time

Step three is because it helps me to count all important images, without having them to rate precisely. I can do that later. It's only to tell me how many images i have at a given time.

Kundal, that's what i suspected. Maybe the different time format causes the problem?

I've been able to reproduce this finally and we should have a fix in the next beta.

Cool, thanks.

This is in beta 15, let us know how you get on with it (and don't forget to report back on your other problem).

Thanks, the fix is working fine here.

Thanks Jon, both issues are fixed now & work as expected.