GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DO12: Right click file properties crash

I'm a long time registered Opus Pro user and have had no issues up through version 11. I'm trying out Opus 12 to see if I should upgrade from 11. After installing 12 it continuously crashes when trying to right click properties for any file or folder. I uninstalled everything I could think of that adds any type of shell menu item but to no success. However after reverting back to Opus 11 with everything I need installed I have no issues. There is something definitely going on with Opus 12 that is causing it to crash when right clicking properties on any file or folder that doesn't currently happen in 11. Until this is resolved I'll be sticking with 11 as it is more stable?

Do you mean the right click itself, or only when the Properties dialog opens?

The dialog is not actually part of Opus, it comes from Windows and Opus just asks for it to be displayed. The result should be the same in Explorer, Opus 11 and Opus 12. But since both the right click menu and the Properties dialog run 3rd party plugins it is possible one is going wrong due to some slight difference in versions (which could come down to something as random as where different versions place their code in memory, if a plugin has a bug that corrupts memory).

Using ShellExView to disable all context menu and property sheet plugins, then rebooting, would be my first suggestion for isolating the cause. If the crash then stops, it implies one of the disabled plugins was involved. More detail on that here:

The crash occurs on the right click itself prior to any menu/dialog being displayed or shown. This behavior is not happening in Opus 11 on the same machine with the same context menu(s)!

In that case the FAQ I linked above is directly relevant and the way to solve it.

It was no issue for my 12.6, but after I upgraded to 12.7, when I click the windows items like "Properties", "Choose default program...", etc, DO12.7 will crash. I checked from internet, looks like the crash issue is not single case, could you please take a look? thank you!

Please follow the guide linked above. It is the way to find out which shell extension on the system is causing crashes like that.

You can also send us crash dumps which we can often use to quickly tell you which shell extension is crashing (or which part of the Opus code is crashing, if it is that, but it is extremely unlikely it is the Opus code crashing if you're seeing problems with things like the Properties menu item, which is not part of the Opus code). Details on that are also in the guide linked above.

ezgif-5-4a5720450a

I tested again, it's no issue from another PC, but only happened on the PC which is Win7 OS. I tried to use Dbgview but nothing detected, looks like the DO12 was shutting down by clicking the windows items "Properties", not crash...
I attached a small gif file to see what happened.

If DebugView didn't show anything at all then the debug mode was not set up correctly.

Please try following the debugging steps again.

Also, what is the extra menu/window that appears when you right click? That looks like something which could be involved with the problem.

Hi, Leo,

Right click on the file, the context menu will popup w/o issue!x, and then left click on the "Properties", Dopus will be turned off and nothing appears...

You can take a look from my Dbgview for detailed information.

ezgif-5-6076458c70

Please post the DebugView log. You can save it using File > Save As from within DebugView.

The log in the screenshot has the side cut off and has been scaled down to make what is there difficult to read, even with the animated gif paused.

Hi, Leo,

Attached please find the debugview log...

Dbgview.txt (47.3 KB)

Thank you.

Please go to Preferences / Miscellaneous / Advanced and double-click ignore_context_menus, then paste this into it:

{CB3D0F55-BC2C-4C1A-85ED-23ED75B5106B}
{D93AE275-4E65-496A-8775-8032FB2072CB}
{3C9D2613-99E5-4732-B8FF-AF05A62CE87A}
{474C98EE-CF3D-41f5-80E3-4AAB0AB04301}
{E0D79304-84BE-11CE-9641-444553540000}
{596AB062-B4D2-4215-9F74-E9109B0A8153}
{A6595CD1-BF77-430A-A452-18696685F7C7}
{389FFE2A-6DE6-49e7-80A7-0DE979C76EC8}
{969223c0-26aa-11d0-90ee-444553540000}

Click OK in that box, and then OK again in Preferences, and then see if the problem is fixed.

If the problem is fixed, please edit that setting again and remove one line, making a note of which line you removed. When the problem comes back, you will know it probably came from the line which had just been removed. Tell us which line that was, and we can advise from there.

Based on the other things in the log, my guess is that {3C9D2613-99E5-4732-B8FF-AF05A62CE87A} is the most likely cause, since it is also spamming the debug log with data, which is never a good sign (except when things are put into a diagnostic mode where they are supposed to output to the debug log). If you want, try putting just that number into the setting on its own as a first test, as it may save you some time. If having just that line on its own solves the problem, then we have identified the problem component.

I tried, it works one time, but after I reboot my PC, same thing agian....almost give up.

Which did you try, the single line or all of the lines?

After rebooting, if you look in Preferences, is the setting still there?

(Also, please link your account.)