GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DO12 - Very slow to launch new lister after last one closed


#1

Hi All,
I have a strange issue after upgarding to to DO12 from 11. I did a complete resore of all my settings.
After closing DO either using mouse (X top right)or alt+ F4. When I relaunch DO using Win+e (all of the things I did previouse version) it takes an extremely long time to launch possibly 2 secs or so. Did not happen with DO 11.
I have checked settings and "Shutdown directory opus after last lister closes" is not checked.
Its as if it is completely shutting down & having to restart
Any advise please.


DO12 - Alias delay
DOpus 12 SLOW!
#2

Is dopus.exe still in Task Manager after closing the window?

Do you have any script add-ins installed? (Preferences / Toolbars / Scripts) Try disabling them using the red (-) button above the list and clicking Apply, then fully exit Opus (via File / Exit Directory Opus) and see if the problem remains.


#3

dopuse.exe is still running in task manager. No I have no scripts at all installed, just a different layout from stock (no special/fancy colours or animations)


#4

If you exit Opus (via File / Exit Directory Opus), is there a similar delay before the program exits, or is it fairly fast?

When you re-launch Opus with it not currently running, is that faster than what you're seeing opening a second window while it is still running?


#5

it's even slower after a full exit


#6

FYI: Did a completely fresh install. (uninstalled using revo uninstaller). Then tried stock version This works fine. Then restored my settings and all is well again. Clearly something went awry during upgrade.
All is super fast again. Just wish the issue with Win+e not being able to open custom (my own) default lister worked but I understand that this is an MS issue with Win10.
Thanks for the prompt responses


#7

I spoke too soon the issue persists. If you open immediately after closing its fine. If you wait a few seconds then relaunch the delay appears again


#8

Delay is 7.3 secs exactly every time


#9

Is it accessing a disk that has spun down and gone to sleep or something?


#10

Nope its on the main OS SSD. Only the toolbars have shortcuts pointing to network drives etc. The default (my own) lister opens left pane to D: drive SSD right pane opens to This PC


#11

Forgot to add the toolbar does have custom icons but no background wallpapers


#12

Ok after testing I have discovered that the culprit is folder tree, within which I have remote paths listed under favorites, such as \server1, \dell etc if these remote sites/machines are removed it works fine. This however is a pain as those remote sites are indeed my favourites. Any ideas on how to resolve? Clearly it's looking for those machines/sites prior to launch


#13

I just wanted to add that I installed DO12 today, and was immediately struck by very slow startup.

I tracked the problem to the favourites (and any smart favourites) in the folder tree.
As NightHawk13 describes, DO12 now seems to attempt to open the network drives prior to displaying the lister window, which manifests itself as extrememly slow startup.

As a side effect of this, collapsing the favourites folder tree, then attempting to expand it again, will lock DO12 for up to 2 minutes.

With the UNC network paths removed from favourites, startup is once again instant..

DO11 (which I was using until about an hour ago) never had this problem. It displayed the favourites by name, but
never attempted to contact remote servers until I clicked on one. Note that since this is a laptop, the remote servers are often unavailable.


#14

Interestingly, if I disable favourites from the Tree, and access them from the folder toolbar, there are no delays.


#15

We'll see if we can stop that from happening for the favorites. Thanks for the reports!


#16

I think I have a handle on this now. As a test, can you try turning off the Preferences / Folder Tree / Appearance / Use configured file display colors for tree items option and see if it makes a difference?


#17

That seems to have done the trick! Thanks very much for the prompt resolution


#18

Thanks for the fast feedback! We'll have a proper fix for this in the next update.


#19

I can confirm that this fixes the problem for me as well. Thanks!