GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Doesn't work properly with Samsung Phones

bug-report

#7

If Windows Explorer works though, much easier to use that.


#8

If you're happy with Explorer. :slight_smile: Most people here aren't.


#9

What is mtp_enable?


#10

It's the setting mentioned in the first reply above.


#11

I get the setting. I'm wondering what "mtp" means/does? I'm trying to better understand the feature/setting.


#12

It's a protocol used for file transfer over USB with most smartphones (other than fairly old ones).


#13

Yeez Leo do you have to bite back all the time? That does put me off posting!

I hate Explorer as much as any DO user, but in this one area it does work better than DO does. I'm not happy at using but I have no choice.


#14

I was explaining that you do have a choice of using FTP or SFTP, which work well (and wirelessly) without the problems seen with MTP on Samsung phones.

Only downside is slightly lower speeds with most wifi, but in most situations that's offset by the bonus of the transfer being wireless.


#15

Okay, I'll try to be less sensitive then :slight_smile:


#16

Have the same problem with Galaxy S8 and S6 Samsung phones.
Been an ongoing issue.

Hangs on jpg file transfer from phone to pc

Tried changes to Enable or Disable MTP
Does not help

Running Opus 12.10 x64
Windows 10


#17

I recommend using FTP if you're having problems with MTP. It's much more reliable, very easy to set up, and lets you transfer wirelessly.


#18

Care to make a recommendation?


#19

I use the FTP Server in Solid Explorer. It works flawlessly. I think someone on this board (Leo, perhaps?) mentioned it and as I was having the same issues as you on a Samsung S6 I gave it a go.


#20

That's what I use as well (since I also use Solid as my file manager on Android, and it's built-in to the same app). But there are lots of others too. I haven't personally tried any others in a few years so I don't know which to recommend, but the Play Store reviews usually cover how well things work.


#21

Ok Solid Explorer with the FTP plugin seems to work pretty good...I want access to my SD card and it does that.
But...Opus viewer pane is not happy when I try to use it on my Galaxy phone.
Actually I can not get any thumbnails or any sort of preview in Opus when I use the Opus FTP function to access my phone?

Is this the same for everyone?
Bug? Or expected behavior?


#22

FYI
When I connect my phone to Opus via USB I get thumbnails...albeit slow and with occasional hanging....


#23

I don't think I ever tried the viewer pane like this before but on checking now it works, albeit very slowly. The same is true for thumbnail generation. My standard use case is to copy from phone to PC using Beyond Compare and that works just fine, and very quickly.


#24

Beyond Compare? In the Google Playstore?


#25

I open a dual lister on my PC with a target (PC) folder on one side and a source (Samsung phone) folder on the other. Options are the Opus's built-in synchronise capability or an external utility, in my case that is Beyond Compare.


#26

Using Opus FTP function with Samsung GS8 on my WiFi with Solid Explorer FTP function

Opus does finally provide a preview in the viewer pane...if I wait long enough.
Thought I may have been a little impatient so I did a quick test.

2.74 meg file appears in 2min 23 seconds
7.26 meg file appears in 2min 48 seconds

Seems strange since FTP file transfers via WiFi seem to happen at a reasonably good pace