DOpus 8 & folder name error

Hi there,

I'm using DOpus 8 and I have some issues with folder names.
I have several FTP servers with a different root directory on 1 HDD.

I've used '%' caracters in these folder names, but DOpus isn't able to open them directly.

I can navigate to the folders, but they won't open directly or from favorites.

When opening, DOpus gives a number 3 error (An error occurred reading folder: system can't find selected path).

I'm pretty sure the folder names are causing the issue (everything else works perfectly), so I could rename, but I rather not do that.

Is there another solution for this issue?

I did a search, but I wasn't able to find anything on this topic.
If there is, please reply with the topic number.

Thanks in advance!

What's the actual folder name?

I tried test%folder, test%folder% and %folder% and they all worked fine with Favorites.

The first two worked fine when navigating by typing and pasting paths into the path field.

The %folder% example confused things slightly, when typing it into the path field, since it looks like an environment variable and when you press \ and then & Opus clears the start of the path. Pasting the full path into the field works fine, though.

Double-clicking also works fine.

If you are referencing paths with % in them in batch files or command-lines for other programs then you may need to double them up as %% to avoid the programs, or Windows itself, interpreting them as environment variables. (That isn't an Opus-specific thing, though.)

First off, thanks for the quick reply!

The actual folder names vary from %ROOT% to %%%%ROOT%%%%.
(root dirs for 4 FTP servers)
Complete paths look like this: G:\FTP%ROOT% .......etc.

Although I said I'd rather not rename, using DOpus has priority for me.
So if there's no other option I will rename the folders.

Funny part here is: I can only rename them with Explorer, DOpus gives the same error message on renaming.

Imho it must be the filenames and not a DOpus related issue, so if you can't give any further assistance I understand.

If you have a clue, please share :smiley:

PS: pasting the full path in the pathbar does open the folders correctly, so for now that would be a nice workaround.

Renaming also works fine for me. Can you give exact details of what you are renaming from and to, and how you're doing the rename? (F2 inline rename? Rename dialog? Simple or advanced rename? Wildcards?)

Because of the '%' issue I tried renaming from:

G:\FTP%%ROOT%% to G:\FTP==ROOT==,

I tried this by pressing "F2" (inline rename) on the folder name.

On renaming DOpus shows the above mentioned error (number 3) and isn't able to rename.

If I try the same in Explorer, I can rename the folders and DOpus can interact with the renamed folders afterwards.

DOpus was/is setup to replace Explorer on the mentioned system(WINXP_pro sp2).

I've checked with Unlocker if there were any other programs using the folders before/during the rename, but other then DOpus, witch makes perfect sense to me, no other application is using the folders.

When I try to open them from the favorites menu, the same error appears, but I can press the "parent" button in the error display that will open the folder:


So to put it short:
everything before the %ROOT% folders can be renamed with DOpus, no problem ;
everything after and including the %ROOT% folders can't be renamed with DOpus and gives the number 3 error message.

PS: the contents of the %ROOT% folders are .bf2demo files (BF2 Battlerecorder generated movies)
Don't know for sure if you needed to know this, just mentioned it to be thorough..

This issue has been fixed in version 9, which should be released soon.