GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Dopus crashes when network folders not accessible


#1

DOPUS (9.1.1.6) routinely hangs, with Windows reporting 'Not Responding' when I try to access a network share which is not available or to which a connection cannot be made. The network sharing problems I have are down to Windows and/or my software Firewall, but surely Dopus should just report 'unable to access...' without crashing? Often I have to use Task Manager to close Dopus and sometimes I have to reboot the computer.


#2

Is it an actual crash (i.e. the program exits or never comes back) or a temporary hang?

Does Explorer crash/hang as well when accessing the same drive?

In my experience, unreachable network folders can cause all sorts of things to hang, even things that don't have any direct connection to accessing the network or drive. You'll probably find that even if Opus didn't hang something else will, giving you odd pauses in apps... It's best to disconnect the drives if they are unreachable, IMO.


#3

The program freezes and Not Responding appears in the Title bar of the application window. Usually you can exit by clicking the X, but sometimes you have to use Task Manager-End Task. Sometimes Dopus will not behave normally thereafter until I restart he computer.

Windows Explorer freezes for a while (presumably while inspecting its toe-nails and discovering that it cannot access the network folder) but doesn't crash.

The frustration, in part, is that the network file-sharing difficulties are intermittent, seemingly unpredictable, and can only be tested by attempting to access the folder through Dopus or WE. Other network functions (internet access) work without problems.


#4

It's annoyed me as well.

I think it's just part of how Windows works, though.

If a network drive isn't responding then sometimes the OS seems to want to wait a very long time before giving up. That waiting can cause programs to wait as well, even when not doing anything that relates to the drive (since they might be waiting on something else that itself is waiting on the drive for some reason).


#5

Hi,
I have the same issue.

For instance, I'm browsing in a tab a share on a remote computer.
If this remote computer is going offline, this opened tab freezes the whole dopus window and I can't even close this tab to recover from it...
I can wait infinitly but Dopus is still not responding any more. Unless I kill the whole process :frowning:
Only "smart" way I found is : unplug the network cable, then Dopus becomes responsive again, I close this damn tab, and from here I can plug again the network cable.

Any other solution from you guys ?

Thx :slight_smile:


#6

I got the same issue, the window explore will be responsed in 15 seconds in same circumstance but dopus never. after I changed to SSD now, I even can't close the tab quick enough in dopus re-opening, as my notebook has no network cable, I tried to disable wifi but dopus still hangs. now I'm not looking for the solution but just want to find a workaround that I can open the dopus again in such a circumstance, is it possible to edit the last tabs in a certain file?


#7

If you can't open a window due to a problem with the last used tabs, the easiest thing is to delete this file:

C:\Users\<username>\AppData\Local\GPSoftware\Directory Opus\State Data\openlisters.oll

You could edit it instead if you want to keep some tabs and get rid of others, but it's probably easiest just to delete it and re-open the tabs you want.


#8

I delete the openlisters.oll but dopus still goes to open the tabs that opened last time.
my env: win10 x64, dopus 10.5.7.0 x64


#9

Try deleting the other file again, and this as well:

C:\Users\<username>\AppData\Roaming\GPSoftware\Directory Opus\Layouts\System\default.oll

Fully exiting Opus (via File / Exit Directory Opus) before deleting either file. If Opus is still running (even if no windows are open), then deleting the files may have no effect.

You may also get better results with a newer version of Opus, since 10 is many years old.


#10

this works, thanks