DOpus doesn't recognize exe files

Starting today, DOpus doesn't recognize exe files. If I double click an exe file a popup says I need a new file to open exe files. If I right click, the menu doesn't give you anyway to open the file either. I tried uninstalling DOpus and reinstalling it, but this didn't help. I have DOpus 11, so I downloaded and installed DOpus 12. Still didn't work.

This may be the solution: Can't launch executables from a lister in a Parallels VM

If not, please make a similar diagnostic file and attach it here.

I searched the registry for HKCU\Software\Classes.exe\OpenWithList and found nothing. I tried HKEY instead of HKCU, and still nothing. When I tried to bring up the DOpus’ Diagnostics, there was no Diagnostics option. I just get "Import, Export, and Close" as the options.

The diagnostic is only part of Opus 12, but if you're back on Opus 11 you can generate a similar thing using my FileTypeDiag tool.

I installed the trial of Version 12 so I could run the Diagnostics. I uploaded below.

Barry (32.7 KB)

Hi Leo, Have you looked at my last post here?

I made it on Dec. 24th.

Sorry for the delay, I lost track of it over Christmas/New Year.

Looking at it now, you ran the diagnostics against the extension .save and not .exe so the attached file doesn't include the information needed to see what is wrong on your machine.

Could you re-run it for the .exe extension? I'll try to look at it ASAP.

I hope I did it right this time. (35.6 KB)

It looks like something (maybe a registry "cleaner" or custom "uninstaller"?) completely deleted the .exe extension from your system's registry:

If you double-click the .reg file within this zip, it should fix things: (432 Bytes)

The .reg file should be OK to use on Windows 10 64-bit. It may also have the correct values for other OS, but anyone who needs them for another version may want to check before using it, in case they are different.

For reference, the .reg file within the zip above contains this:

Windows Registry Editor Version 5.00

"Content Type"="application/x-msdownload"