Dopus is slow and freezes when downloading files to NAS box

Win 7 X64
Dopus (5016) X64
Thecus N7700 on the latest firmware

When I download multiple files (2-4 at the same time), dopus runs slow and if you try and navigate or edit any folders dopus just freezes (not responding). When the downloads have finished dopus remains slow for several minutes, the only way to restore the speed of dopus is to exit and restart. This problem only happens when downloading files, transferring and extracting files are not affected, just downloads.

I have tried different copy_buffer_size and copy_nonbufferio_threshold settings without any improvement, hopefully someone has experienced a similar problem and can point me in the right direction to a solution.

Thanks for any replies in-advance :thumbsup:

Does it matter which types of files you are copying?

If you're copying movie files, it's possible a video codec/splitter on your machine is being asked to inspect the half-written file, and going wrong as a result. I've seen that happen with some bad codecs/splitters which can't deal with unexpected inputs, and updating/replacing the codecs/splitters solved the problem.

If it's not movie files, this is less likely, although not impossible (e.g. downloading large/partial zip or exe files may trigger antivirus scanners to do silly things).

Using tools like Process Monitor to see which files are being accessed while things are slow/frozen may shine light on where the problem is. Similarly, Process Explorer, if you're familiar with it or fairly technical and can understand it, can show you which threads in the process are active and which DLLs they are running code from. Both may point to a shell extension that's going wrong, or to calls to Windows APIs which are blocking due to the NAS misbehaving (another possibility).

It's worth checking with Thecus's support forum to see if anyone else is seeing similar problems, too. The NAS may have general issues with programs downloading data from it while trying to access it in parallel, possibly ones which don't show up in Explorer but do show up in other things. This has happened several times now with some NAS manufacturers, and it seems like at least some of them only test things with Explorer and thus miss out on problems caused by anything which is slightly different.

Really strange, I've been testing all possible senarios, copying, moving, extracting and downloading data and dopus has been fine for the past 4 hours. I've just had a 15 minute break and the problem has returned! I have downloaded 3 files (251mb) and Dopus has frozen, displaying a blue icon. If I try to scroll up or down the folder tree I just get the doughnut of doom, then it moves a little further down and freezes again. The files have just finished downloading and Dopus is still laboured and responding slowly. My system never sleeps but my monitors shut down after 10 minutes, it makes you wonder if a driver is causing the issue, I will try to replicate the problem once Dopus recovers.

Any thoughts would be appreciated :thumbsup:

Blue icon is for dual lister mode, so nothing to do with Dopus freezing then!

After 20 minutes of waiting I shut down Dopus and restarted and everything is back to normal.

Now that my subscription with Kaspersky has finished I thought I would eliminate any anti-virus software from the equation. First step, disable Kaspersky before uninstalling, unfortunately no difference. I then uninstalled Kaspersky and re-booted, no difference. I then used ccleaner for a full system cleanse, no difference. I have now installed Webroot SecureAnywhere Anti-virus, so I think we can safely say my anti-virus software is not causing dopus to slow down or freeze.

Is the machine low on memory when things slow down?

(How to find components causing memory leaks may help, if it is.)

Registry cleaners are unlikely to help here and more likely to cause problems.