Dopus lost the *.mht and *.eml preview in dopus preview pane

Hi forum,

I used to be able to preview *.mht and *.eml files just fine in the preview pane in their original format, using the ActiveX document viewer plugin.

For some reason, this is gone, and *.mht as well as *.eml files are displayed text-only in the preview pane.

However, *.htm files still display perfectly in the preview pane. Even the thumbnails for *.mht and *.eml files are still created and displayed.

What could be done to fix the *.mht and *.eml preview display?


I don't think the ActiveX works with .eml and .mht (yet anyway). Were you viewing them via the MultiView plugin + QuickView DLLs instead?

Well thanks nudel, but of course .eml and .mht normally work like a charm in the Dopus preview pane. These are standard Internet Explorer formats that are handled very well by the ActiveX viewer plugin (however not at all by the MultiView plugin + QuickView DLLs).

Only thing is, nobody seems to know about it and therefore also the standard file format for .eml and .mht in Dopus is wrongly configured such that the preview doesn't work initially.

Usually it was just a matter of changing the file type "message/rfc822" for .eml and .mht in Dopus and the preview would work.

Unfortunately I don't remember anymore what file type made the preview work -- and a recent install and uninstall of IE7 seems have to mixed up these settings.

Hopefully somone who has a working .eml and .mht preview in Dopus can give me the right settings for it,


OK, I found it in an old e-mail I once sent to the German distibutor Haage who also didn't seem to know about that feature :wink:

It's a matter of just registering the MIME file types for .mht and .eml as


not as "message/rfc822" as they are incorrectly designated in Dopus as a standard.

Recapitulating, the .mht and .eml preview is back :wink:

Cheers, David.P

(broken image link)

Interesting, I didn't realise the ActiveX viewer would show those formats with such a simple settings change.

I'll have a look at making this happen automatically, or not require the registry settings at all.

Many thanks for the follow-up info!

Maybe i'm blind, but i can't find the mutipart/related mime type.
Is it created with a application ?
I'm mostly using the mht format with Firefox to archive HTML page.

You go

Settings -> File Types -> System File Types -> MHT -> Edit -> Mime Type

You paste "multipart/related" into the field, whithout the quotes.

Same for the EML file type.

That's all.


I didn't know i could paste things in the field, so i did it in the regidtry before reading your post.

Thanks anyway, now i know.

Since I've just lost the MHT preview in Dopus again, which happens to me about every couple years, and since I myself seem to be the only source for this problem on the Internets, here's a screenshot of how I solved it this time. Note that it only works when added to IE 64-bit, not when added to IE 32-bit.

Of course, and as also many times before, the MHT preview does also not work anymore in Windows Explorer...

If anybody has a clue about how to reliably solve this, let me know

You would normally have a Windows Mail MIME MHTML viewer in the top section of the list. That viewer comes with Windows.

If that's missing or disabled (or has the file extension removed), the 32-bit Internet Explorer line also has the MHT extension by default and still works when I test it today in Windows 10. The 64-bit version of IE should also work, but isn't the normal one to use.

Something seems to have broken parts of Internet Explorer and the underlying HTML components on your machine.

1 Like