GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DOpus pinned to taskbar not opening changed setup lister


#1

This is a weird situation. Using Win7 64 bit I have DOpus pinned to my taskbar next to the Start button. I'll call it the "pinned icon" from now on since there is also a taskbar icon to the right next to the time and the can't both be called taskbar icon :smiley:
I've set up DOpus to open the lister named "Standaard" when double-clicking on the desktop or taskbar icon. When I start DOpus left-clicking on the pinned icon it also starts with the "Standaard" lister just fine.

A week ago I changed the layout of the "Standaard" lister. Double-clicking on the taskbar icon or the desktop opens the new "Standaard" lister, however left-clicking on the pinned icon opens the previous "Standaard" lister. Unpinning and repinning has no effect. I can right-click on the pinned icon and choose the "Standaard" lister and it will open the new "Standaard" lister, just not when single left-clicking on it.

What am I doing wrong here?


#2

Use Settings -> Set as Default Lister to update the default lister, and you might want to change the Launching Opus settings to open the Default Lister instead of your "Standard" layout to keep things simple and make it so you only have to update one thing instead of two (although you don't have to, of course).


#3

Hi Leo,

Thanks for your reply.
Save as Default Lister has no effect. Already tried that a couple of times before and just now, with the latest beta installed. Know anything that might cause that?

Perhaps an option for Win7 users to set a lister type to be opened from the pinned icon?


#4

If Opus is already running then the pinned icon should just open the Default Lister.

If Opus isn't already running then the pinned icon should do what's set in Preferences / Launching Opus / Startup.

(Remember that Opus continues running in the background by default.)

If that isn't the case, try fully exiting Opus, then unpin the icon, launch Opus via the Start Menu, and then re-pin the icon. Maybe the old pinned icon inherited some command-line arguments from somewhere.


#5

Just did an Exit DOpus as instructed, only DOpusRT.exe was running. I then started the Sysinternals Process Monitor to see what lister was loaded, and the default lister was indeed loaded when starting DOpus.
Here is what the C:\Users\Standaard\AppData\Roaming\GPSoftware\Directory Opus\Layouts\System\default.oll looks like:


<?xml version="1.0" encoding="UTF-8"?>
<lister_layout flags="1">





D:\Downloads






<4>
D:\Downloads
</4>



D:\Downloads






<4>
D:\Downloads
</4>



<initial_layout>Dual Vertical</initial_layout>

</lister_layout>

This layout however is being ignored and what is being loaded is this:
(I saved this to be the default layout in order to being able to show you this)


<?xml version="1.0" encoding="UTF-8"?>
<lister_layout flags="1">





D:\Downloads






<4>
D:\Downloads
</4>



D:\Downloads






<4>
D:\Downloads
</4>



<initial_layout>Dual Vertical</initial_layout>

</lister_layout>

This layout does not exist on C:. This is what my old "Standaard" lister looks like, but not the new one nor the default lister. I even deleted the default.oll-file and copied and renamed my Standaard.oll to default.oll. All after fully closing all DOpus processes. Still nothing.

I'm a programmer as well, so I understand the need of more details to figure a possible bug out. Let me know if there's anything I can do to help.


#6

The difference there is all in the folder format (columns etc.), so you've probably got Preferences / Launching Opus / Default Lister / Ignore folder format of Default Lister, and your default folder format isn't the same as the format you've saved in your "Standaard" layout.

If you want that folder format to be used everywhere by default, I'd leave the option on and follow the guide to make your desired format the default. Otherwise the format will start changing when you go into different types of folders, even if you get it how you want when the windows first open.


#7

I'll give it a try, thanks.


#8

Setting "Preferences / Launching Opus / Default Lister / Ignore folder format of Default Lister" to off fixed it, thanks.
Still wondering though where the old format which shouldn't exist comes from.


#9

It's coming from your folder formats. You can set the default folder formats by following the guide I linked above, which is a better way to solve the problem than turning off that option.