GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Dopus Rename/Copy Crash


#1

Ok, forst I acknowledge there might be something wrong with one of my computers because it works fine with one. However on my daily computer, I can’t use Dopus because of constant crashes that happen ONLY when pressing Ctrl-A or trying to rename a folder. I have a screen capture of a debug session.


#2

Crashing inside HeapDestroy suggests something is corrupting memory within the Opus process (e.g. by freeing a block of memory twice).

It could be part of Opus itself, but that’s unlikely as we’d expect more people to be reporting the same problem in that case. (Although it is, of course, possible that something unusual is triggering an obscure bug.)

More likely is that a shell extension, video codec, plugin, or similar DLL that gets injected into dopus.exe is causing the problem.

Crash, exit or high CPU when viewing certain directories has suggestions which may help track down the cause. (Some of the Other Troubleshooting guides in the FAQs may also be useful, but I’d start with that one.)

Since you’ve got the Windows debugging tools installed, it may also be worth turning on PageHeap, which will add checks to all heap memory operations and may catch the problem when it occurs and point to the code causing the problem. (Without PageHeap turned on, it’s a case of something making a mess and then leaving the picture, and the crash happening when something else trips over the mess.)

[ul][li]To enable PageHeap, open an administrator command prompt and run this command:

“C:\Program Files\Debugging Tools for Windows (x64)\gflags.exe” -p /enable dopus.exe /full /protect

Use File > Exit Directory Opus, then restart the program. (Don’t just close all the windows as it stays running in the background by default and needs to be fully restarted for PageHeap to take effect.)

Note: Opus may run very slowly when PageHeap is enabled, due to all the extra checks the operating system is doing.

If you can then get the crash to happen again, and use WinDbg like in your screenshot, it will hopefully reveal something useful.

[/li]
[li]To turn off PageHeap and return to normal, run this from an admin command prompt:

“C:\Program Files\Debugging Tools for Windows (x64)\gflags.exe” -p /disable dopus.exe

Use File > Exit Directory Opus, then restart the program and Opus should run at full-speed again.

[/li]
[li]To find out if PageHeap is enabled for dopus.exe (or anything else):

“C:\Program Files\Debugging Tools for Windows (x64)\gflags.exe” -p

Handy if you’re not sure if it’s on or off at the moment. It should normally not be turned on for anything that isn’t being debugged, since it slows things down so much.[/li][/ul]


Crash of DO direct after restore of groups
#3

Hi Leo, thanks for your suggestion. I’ve enabled the page heap protection and now Dopus is not crashing lol. I currently have the Windbg as the post-mortem debugger and it would start automatically on unhandled exceptions. But now it wont start probably because of the page heap protection. Dopus used to crash predictably, and some times only in one of the listers, the other was not. That’s why it drives me nuts :slight_smile:. I agree it might be one of the shell extension, I’ve got a bunch of them but I’ve also disabled some using the SystemIntenals Autoruns program. For some reason I’ve suspected the OLE system because it happened when mostly when trying to use the clipboard but I’m no expert. I’ll keep trying though, it’s not that slow.


#4

I’m going to try to compare the crashing PC setup with my other PC that’s fine and see what extra extensions I have. Could DaemonTools cause the problem?


#5

A wait a second I do have Nvidia shell extension. I’m gona try to disable it.