GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Dopus using 7GB of RAM


#7

Thanks. ShellExView tells me there are 228 extensions. I can't imagine how I can narrow this issue to prevent it.


#8

Did you try looking at the FAQ Leo suggested?


#9

Yep, we had a dialog late 2011 here:

Occasional excessive memory consumption

I think some of the conversation was offline (or in some other thread).

Unfortunately vmmap itself ultimately crashed. The problem is infrequent enough that I can't get vmmap to run over that duration, so it is not useful here. And since I don't know the steps to reproduce or trigger, it is unclear how/when it will occur.


#10

Most of them are usually Microsoft ones which can usually be discounted. What are the other ones?


#11

Here's the list:



#12

Disable all of them except the MS and Opus ones.

If the problem stays away, enable half the ones you disabled to see if the problematic extension is in that half or the other half, then repeat until you've narrowed it down to a particular extension.

(Assuming it isn't a really nasty problem, like one which only happens when two things are enabled together. That's pretty rare, though.)

Just in case, after enabling/disabling a batch of extensions, fully exit Opus and restart it, to make sure nothing was left lingering in the process. (Some extensions create their own background threads the first time they are used, for example.)


#13

Of course that makes sense. And yet, without a reliable way to reproduce it, I'll really never know when to move onto the next batch. Because I haven't noticed the problem since Oct 2011 (possibly just due to reboots, etc.), quick math tells me the divide and conquer strategy make take several years to narrow!


#14

If the problem only happens once every 9 months then I don't really know what to suggest to help you track it down. There's no good way to test theories if it can take that long to occur (between which time the computer will change anyway).


#15

I think I have figured out what triggers the problem. If I have a lister open with the uTorrent program directory open RAM usage keeps going up indefinitely. Even after closing the window it does not go back down again.


#16

I'll also provide some additional findings.

Since I switched my desktop systems, I no longer have to remote connected via RDP (using Microsoft's RDP client Remote Desktop Connection) to the machine running DOpus. I've not had a problem since, so at this point I'm calling this one related to RDP sessions. The memory swell occurred only late in the night (i.e. only after dropping the RDP connection), and never while I was directly using the system, so this is consistent with the theory.


#17

Hmm, I use RDP as well and still am. Then again it has had a few updates from MS lately.


#18

I use RDP constantly (Win7 to Win7) so it is unlikely to be that, at least not in isolation. (Could still be a factor if combined with other software/drivers/settings, of course.)


#19

From a Mac? Microsoft's RDP client for the Mac is buggy and drops the connection (or fails to connect) frequently. MVP's on their Office board say its not supported in the past two major Mac OS X releases. So this may very well be the difference between what we see. Or not.


#20

No, from a PC, Apple products are banned here.


#21

Spoke too soon, it's still boned.


#22

Has this been fixed in V10? I have the latest V9 and although it seems to happen much less often now it still happens.


#23

I don't think there is an issue in Opus to be solved here. Memory leaks which only one person reports are almost always due to shell extensions (or similar 3rd party tools/components which hook into other software).

There are no shortcuts here, you need to use the guides already linked to if you want to track down what's causing the problem.


#24

It's a fresh install of Windows 7 SP1. Only Opus, TrueCrypt and Firefox are installed. TrueCrypt and Firefox don't have any shell extensions. The machine just serves files over standard Windows shares all day, nothing more. Also, if it were a shell extension wouldn't it affect Explorer as well? I have tried having just Explorer open and it doesn't seem to happen.

Oh, and my mistake, I meant I am on V10 and was wondering if V11 had fixed this flaw.


#25

Since someone revived this thread, I'll post and update to my experience here. Since I stopped using Microsoft's Remote Desktop Connection (RDP client on a Mac), the memory exhaustion problem has not recurred (that's 9 months now, where it used to bloat several times a week).


#26

It only seems to affect machines I RDP into as well. It must be some issue with Opus and RDP. Nothing to do with shell extensions.

So is this bug even open? Is there any chance of it being fixed? I presume Opus 11 still has the same flaw, so there is no point upgrading. If there is a fix will it be available for users of V10 or will I have to upgrade?

Come on guys. I'm very happy with Opus for the most part but the lack of fixes for ancient bugs is very frustrating.