DOpus v10.0.2 crashes and other issues

  1. I still experience the same issue which started with version 10 regarding network drives:
    Set up: Explorer mode (folder tree - left, files - right); DOpus on USB.
    Issue: When exploring network drive and pressing F5 (refresh), network drives got closed and cursor goes at the top of folders (in my case – Desktop).
    This happens only when I go directly to network drive pasting server name (i.e. \sew012345\F_Abcd\webroot\abc\Files)
    If I am on a network MAPPED drive, everything works as expected. Mapped drives do not get closed, only drives with server(s) names.

  2. Set up: Windows 7, Aero on.
    Issue: I believe line spacing (between folders and between file names) has been increased for a couple of dots so it looks kind of weird. I have no such feeling on Win XP. Another thing is that Win 7 for some reason overrides my file selection color so instead of dark blue (background of selected file/folder) becomes light blue. Not really to my liking… I want Dark blue as I selected through preferences.

  3. Do not like much to click on METADATA all the time when I want to edit MP3 tags but could live with it. Problem is that upper part shows hex file content and I cannot play the song as before through Viewer Pane. My player is WinAmp…

Sometimes new ideas and implementation are not the best. Viewer Pane should be left alone and it should keep its ‘intelligence’ and ‘figure out’ am I on a song or picture or whatever.

Forgot the crash error: Ugly error box appears when F5 on network drive. Have a picture and if I figure out how to post it, you will see it.

Found it...

General point: Please ask one question per thread.

Q1 & the crash may be related: Most likely caused by either a 3rd party shell extension or a 3rd party video codec. See the quite Crash, exit or high CPU when viewing a certain directory for advice on tracking it down.

Also, if you have the Qualcomm/Atheros bluetooth drivers installed, the shell extension they install has been causing a lot of crashes recently. Details here.

Q2: Turn off Preferences / Display / Options / Use visual style to draw items (Vista/Win7 only, overrides background colors).

Q3: See Enable/fix playback of various media formats in Opus.

Thank you Leo but nobody still explained why F5 on a directly accessed network drive moves cursor to the top of the folder tree and removes all network drives from the tree??????
I reported this when you come out with v10; somebody opened a case and claimed later that is was fixed. well, it is Not!
I do not have any third party shell extensions nor video codecs.

I never had such problem with v9. And v9 never crashed like v10.

It may still be worth going through the info that Leo referred you to about troubleshooting "Crash, exit or high CPU when viewing a certain directory"...

But, since you said "somebody opened a case and claimed later that is was fixed"... what does that mean? Whose "somebody"? Did you yourself open an official support case with GPSoft and get a response stating it was fixed in a particular release? If so - why not follow-up with that support request?

You mentioned running Opus from USB in that case - where it looked like you were running it on an XP system...

  • Does the crash happen on any system you run Opus from?
  • Is it specific to running it from USB (shouldn't be)?
  • Has your command been modified, what command does it actually run, just Go REFRESH=source?
  • Is it specific to certain network resources that you're browsing, and if so, what type of network shares are they - or does it happen no matter what network resources you're browsing?
  • Does it happen all the time - or only sometimes?

I do not know of 'any' other system since I use USB version at work only where I access those network drives.

No idea. I am not going to install DOpus at company's PC to check that out.

How can I Simply check what is assigned to my F5? I did not change anything default in DO except adjusted status bar to show values I care for.

I am not a network guy so cannot answer those questions; as I said before, when I access server directly typing server name - it happens; if I have mapped server to A, B, C, etc. it does not.

It happens Every time and after 2-3 times it crashes with nasty message box.

It is interesting 'steje' that you ask these questions without any research/search in this forum. YOU WERE replying on one of messages regarding my first reporting this issue with V10... do not remember, right...
Leo opened a case and claimed later that it was fixed.

[quote]Re: Weird navigation issue.

Postby leo » 06 May 2011, 07:19
Thanks. I think I've been able to reproduce what you're seeing. For me it seems to help being in a directory that is next to a lot of other directories, and near the bottom of the list. If I refresh quickly while the tree is still re-populating the list of other folders then I sometimes get dropped back to a parent folder. I'm writing up a bug report about that now.[/quote]

I reverted to V9 for USB use. Difference I can see right away is that v9 does NOT show network places (or whatever was there) in tree portion and that weird behavior does not happen. I suspect with v10 as DO can show the whole network it somehow gets confused with all those network drives.

I think the issue that you're talking about, that was fixed, is unrelated to the problem you are seeing.

Please go through the guide I linked in my previous reply which has suggestions on narrowing down the cause of any crash that happens when changing folders.

Until we know what is triggering the crash -- and it's usually a particular file that you have in one of those directories, which triggers a bug in either Opus itself or in 3rd party software that runs inside of Opus (e.g. shell extensions, video codecs, anti-virus...) -- we cannot do much about it because it's so far only happening on your machine.

Also, see if any crash dump files have been created. If you send those to us they will sometimes (not always) indicate which component the crash is happening inside.

Probably an unrelated crash, but I had one last night. Seems like it might have been related to RDP. Anyone want the .dmp file?

PM it to me if you like.

If you're still using as per your sig, make sure it wasn't just this, as it was the cause of a lot of crashes for people who had that Bluetooth stack installed.


Version-wise, Dopus is up-to-date, but sig. was not. Thanks.


[quote="Adamov"]It is interesting 'steje' that you ask these questions without any research/search in this forum. YOU WERE replying on one of messages regarding my first reporting this issue with V10... do not remember, right...
Leo opened a case and claimed later that it was fixed.[/quote]
I don't know why you feel the need to respond to the questions as if they were antagonistic... they certainly weren't intended to be. They were just questions - asked out of a genuine interest in trying to help, some of which wouldn't have been necessary if perhaps you'd have chosen to just re-visit the other thread you started on this same issue to ask for help again - instead of starting yet another new thread with two additional unrelated issues thrown in. This may be partially why the admins suggest you only post one issue per thread... Looking back, I now see that your first post about this problem was in someone else's thread that had nothing to do with your specific issue, after which you did indeed open another thread specifically for this issue (which was good) where Leo clarified that while a "similar" problem he had reproduced had been fixed - he still suggested that you " GPSoftware Support (link in my sig) to send an official bug report" which I'm guessing you still haven't done since it's appeared again in this new thread?

At any rate, I've tried to repro this several more times (though admittedly only from Win7)... with various types of network resources, and still can't reproduce it. I'm not a network guy either, but I know that the various resources I've tried are a combination of Win2003 servers, another Win7 share, and several NAS appliances. My question about trying it on other PC's was to find out if it was something that seemed specific to one particular PC. Especially since it seemed like the system you posted the screenshot of this problem of seemed like it came from a WinXP system - but one of your other (unrelated) questions mentioned Win7, I wasn't sure if they were both in the same environment or not in order for you to provide some insight about whether you did in fact see the same problem from multiple systems. Since you're running it at work from USB, is there any chance you could try the same thing from a co-workers PC? If it doesn't happen - it doesn't really help discover what's triggering it - but it might rule out the specific type of network resources themselves as being a relevant factor.