GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DOpus won't open PDF in assigned app


#1

I have DOpus set to open PDFs with PDF-XChange Editor. I've double checked this in Settings/File Types, and it's set correctly. In Windows I also have PDF-XChange Editor set to the default app for opening PDF files. In Windows Explorer this works fine, but whenever I go to the open a PDF by double clicking on it, Photoshop opens up. It can't open the file, so it doesn't display anything, just opens to the default PS screen. I've searched through the File Types dialog for all file types set to open with PS, and there's quite a few of them, but PDF is not one of them.

Any guidance as to how I might fix this?


#2

I have the same setup and it is working correctly.

In Settings - Apps - Default Apps - Apps by file type I have this:

image


#3

Right-click a PDF, select Open With > Choose Default (or whatever the bottom menu item is callled; the name varies) and select the app you want, and make sure the checkbox to change the default is selected.

That will usually fix any double-click issues with PDF apps fighting over which gets to be the default.


#4

Thanks for your replies. Per Surfrat77: that's exactly my setup.

Leo—I've done that repeatedly, and I've tried rebooting after doing it, but it keeps firing up Photoshop when I double click on the PDF.

I just backed up my configuration, then uninstalled and reinstalled Dopus. It correctly opened a PDF with PDF-XChange Editor. I then restored my configuration, and the problem recurred.

Resetting to default toolbar sets does not fix the problem.

Is there any reasonable way to debug this, or am I best off doing another uninstall/reinstall and rebuilding from scratch? If that's the case, is there a way to save a toolbar configuration without saving the entire configuration?

Thanks again for the help.


#5

Something in your Opus file types config must be overriding things.

Please go to Settings > File Types, then File > Diagnostic at the top left, and generate a diagnostic file for the pdf extension, then attach it here.


#6

Opus_FTD_File_pdf.zip (50.4 KB)

Here you go, let me know what you find.


#7

Go back to Settings > File Types, double-click the .pdf file type, on the Events tab, delete the Double-Click event, which is currently set to force PDF files to launch Photoshop when double-clicked.


#8

That did it, thanks! I never would have found that on my own.