Dopus12: Issues on renaming images from the image viewer

Renaming images from the image viewer via simple F2 or rename scripting results in the files being properly renamed but the changes are not reflected in the current image viewer instance. They're also excluded from the previous / next queue until viewer restarts.

After rename this is what happens:
[li]The viewer's titlebar retains the old filename[/li]
[li]Attempting another rename again results in a file not found error.[/li]
[li]After renaming > going to next image > going to previous image - renamed image is skipped[/li][/ul]

What would be normally expected to happen:
[li]Titlebar should update with the new name[/li]
[li]Another rename should work on the current (actual) name and not the one when it was launched / navigated to.[/li]
[li]Image position and name should be properly updated in the internal list (following the lister sort / filters accordingly) so that it keeps its place in queue when using previous / next.[/li][/ul]

This is supposed to work, and does here in a quick test.

Where are the images located that this happens with? If you try with a simple folder of images on a local hard drive does it still do it?

Forgot to specify my version: 12.2.5 x64.
The folder in question is located at /desktop\Images
It's view is set to details, grouped by file created date and sorted by the same. Only present columns are Name, Size, Type, Created.

And it seems you're right. It does behave correctly for files directly on the desktop.
The folder where it does not behave correctly has some ~10000 images (8GB) in it. That might be the cause but I'll investigate further to see if the image count is making it behave that way.

My bad. It was a symlink to another smb host and not a local folder. I realized it too late.
Also reducing the image count to 10 images I still get the same result.
Occasionally I use IrfanView for resizing and it behaves properly as I described above even with the simlinked folder.

The link command was:
mklink /D "%userprofile%\Desktop\Images" "\SERVER\C$\Images"

So to sum it up:[ul]
[li]Browsing local folders: everything is OK.[/li]
[li]Browsing remote folder directly on \SERVER\C$\Images - the image viewer behaves correctly.[/li]
[li]Browsing local symlink-ed folder of remote \SERVER\C$\Images - the problematic behavior.[/li][/ul]
The strange thing is that the lister browsing the symlink-ed folder is notified immediately of the changed name and reflects it flawlessly.

I hope this helps in getting to the bottom of this.

Ok, thanks. We should be able to fix this in the next update.