Download of 12.5 failing

I have been able to upgrade 2 of my computers successfully, but on one of the computers nothing happens when I press on Download. I tried going to the gpsoft website and downloading it and DOpusInstall.exe says failed-network error.

Could your antivirus/firewall be blocking the download on that computer? Is it able to download other installers from the web?

Since everything is working on two of your other computers, it's likely to be something specific to the PC where it is failing, rather than something on our side (else it would not work on all three).

The firewall was the issue. Our IT consultant said there is no easy way to get the firewall to accept it, so I will have to uninstall DO in the future and then have them download the new version when it is updated and transfer the file to me.

A little bit of a hassle, but it worked.

Thanks.

You can run the newer installer over the top of the old one. That's all the automatic updater does, too.

No need to uninstall first, and doing so will wipe your config.