Duplicates Feature Not Working

I'm at a loss. I'm trying to delete duplicate files within a directory. The manual says when I check the "delete mode" then Opus will "automatically select all but the first file of every duplicate file group." However, it doesn't. All it does is add checkboxes. No checkboxes are selected. Is this a bug or am I doing something wrong?

Opus 12.22 x64, build 7593. Windows 10.

Can you show a screenshot of what happens?

Clicking the Select button in the duplicates panel should also perform the same selection.

Okay... this is strange! I've tried this multiple times with the same results. In order to show you a screenshot, I did it again, but this time I checked the "use MD5 cache" thinking it would process faster (it's a large folder). Now, the checkboxes for the duplicates are selected! No idea why the cache option made a difference??? I've been playing with this for over a month. I've tried this dozens of times. It never worked until now with that cache checked. AUGH!

The cache option shouldn't matter, at least in terms of the checkboxes.

I realize that... that's why this is strange.