Error in thread 'dopus_fileinfo'

I have been using Opus 9 for several years with hardly any errors or problems at all. But since upgrading to version 10, I get the following error message:


It seems that the error occurs because I have set Opus to show Dimensions for all folders. The error will typically occur when I have double-clicked a tiff, and am working on it in Photoshop. I click yes in the dialogue above, and can continue working. However, I cannot save the tiff I'm working on, and get an error message saying that the file was left open or is in use by another application. So i close Opus, but still cannot save - I have to kill dopus.exe to be able to save the file.

I have now set Opus not to display Dimensions, and the problem seems to have gone away. But I would of course prefer to be able to see the dimensions. I'm using XP SP3, 32-bit.

If you can zip & attach a TIFF file that reproduces the problem we should be able to fix it.

Please try with 10.0.0.3 (released earlier today; link in my sig) first in case it has already been fixed, as there are some updates to the TIFF library in that.

I installed 10.0.0.3, which seems to have stopped the program error. But saving large tiffs with dopus.exe running is still not possible. In addition I got this message:


I tried saving a smaller tiff, which went ok. The tiffs I am working on currently are 16-bit, around 290 MB. I can send you an example via Filemail if you want me to.

How big (dimensions) are these TIFF files? I'll see if I can reproduce it by making one myself.

They are approx. 8000 x 6400 pixels, 16-bit RGB, uncompressed.
I remember now that I occationally have had similar problems with saving large files in Photoshop before. I never thought it had anything to do with Opus, because PS is very picky about saving files, and doesn't like saving over a network, or to external disks - for instance. ( I'm now saving to a local disk)

Thinking back - I think I might have started to work on big files in PS about the same time as I started to use Opus - which was when version 9 was released.
I should add that this saving problem doesn't always happen, but becomes much more likely to happen, the more work I do on the file. (within the same session)
I should also mention that I can always do a Save As, under a different name.

But he fact that I now seem to be able to do a Save whenever dopus.exe is not running, seems to indicate that the problem is Opus related.

Is it possible that you're running out of memory?

Editing an image that size on my machine, Photoshop CS4 is using over a gig of RAM (and I'm not doing much in it), which increases by a few more hundred meg while saving.

When Opus scans the file for its dimensions etc. it loads the whole file into memory for a moment (which I'll look into; not sure if it needs to do that for TIFF files) which will use a few hundred more meg during that time.

Since you're on a 32-bit OS, that sort of memory usage could be pushing the limits. What does Task Manager's Performance tab show for memory usage while the save is happening?

I only have 4 gigs of RAM, so PS quickly runs out of RAM, and uses the scratch disk instead (which is a dedicated partition on a drive that does not contain C).
The screenshot below shows the Taskmanager at a point where I couldn't save.


Then I right clicked the Opus icon in the taskbar, an chose Exit, (no need to kill the process) and was able to save.
Next I restarted Opus, then launched Lightroom and InDesign as well, then opened a new 290 mb image in Photoshop. After some editing, the PF Usage was 2,30 GB. The same thing happened again couldn't save with Opus running, was able to save as soon as Opus was closed.
And the error message I get when PS won't save is this one:


I can still do a Save As under a different name without any problems, even when the computer is choking from RAM starvation.

Does disabling (un-ticking) everything under Preferences / Viewer / Viewer Plugins make any difference?

If not, do you see the same problems if you load the attached TIF file into Photoshop and try to re-save it? It's a test 8000x6400 uncompressed 16-bit TIFF I made. Since it's a simple image it zips down to a reasonable 3MB, but unzipped is 626MB.

BigTiff.zip (3.07 MB)

Hmm, just realised another possible problem on a 32-bit OS could be a lack of available address space, even if there's free RAM/swap-file. Each 32-bit process usually only gets 2GB of address space to use and there might not be a contiguous 600MB chunk of it that can be allocated for loading the file into memory.

No, unfortunately not

And the tiff I downloaded behaved excactly the same way.
But there something funny going on - I wanted to delete the BigTiff as well as BigTiff2, which was a Save As, and Opus gives me this message (Photoshop was closed)


So I closed Opus, and was the able to delete the files with Windows Explorer ...

Just to confirm the problem, I have been working in Photoshop all day, with Opus closed, and Windows Explorer open - no saving or deleting problems at all.

After looking into this a bit, it seems Photoshop adds a huge amount (e.g. 300MB!) of proprietary data to the TIFF header which then gets read into memory by most TIFF libraries even if just opening the file to get its dimensions. It's only kept in memory for a moment, but if the allocation fails it might be what's causing the problems you are seeing.

I've made a change to the TIFF library Opus uses to make it ignore the Photoshop tag, which may help. (The tag has no meaning to anything other than Photoshop, so reading it is a waste of time anyway.)

However, when Opus asks Windows if the file has any metadata attributes/properties that also causes similar memory usage for a moment. There isn't much we can do about that, since it's happening in code that's part of Windows itself, but hopefully it isn't that code which is/was causing the problem.

The change I mention will be part of the next update.

I upgraded to 10.0.0.5, but unfortunately the problem persists. (Could not save xxx.tif because the file is already in use or was left open) The problem will appear when a certain amount of memory has been used by Photoshop. (I can't say excactly how much)
I have done some testing with different listers, and here are the results:

  1. Having only a default lister open does not seem to cause any problems. The default lister does not read any particular folders, only drives.

  2. Having an open lister that reads the folder where I'm saving from Photoshop (and where the file was opened from) will cause the problem to appear.

  3. The problem will also appear if any open lister has previously (in the same session) read the folder I'm saving to. Closing this lister will not cure the problem.

  4. Exiting Opus will cure the problem. (dopusrt.exe still running)

  5. Working with Opus closed and Windows Explorer open and reading the folder I'm saving to works perfectly.

Try the following:

[ul][li]Disable everything under Preferences / Viewer / Viewer Plugins.

[/li]
[li]Exit and restart Opus. (Make sure the first folder you see when you restart isn't the one with your TIFFs.)

[/li]
[li]Remove all columns except for the Name column.

[/li]
[li]Turn on the Format Lock, in the status bar. (So that the columns don't change from now on.)

[/li]
[li]Go to the folder with the TIFFs.

[/li]
[li]Try saving in Photoshop.[/li][/ul]

Do you still get the problem then?

Disabling all viewer plugins AND removing all columns except Name seems to have fixed the problem.

Okay, so start enabling them again and see which thing(s) seem to trigger the problem.

This is very confusing.
I started by enabling all viewer plugins, and with only the Name column. This went OK, so I added the Dimensions column, and still no problems.

Then I added the Size column (keeping Name and Dimensions), this was Ok for quite some time, but all of a sudden, I couldn't save. Removed the Size column, and was able to save. Added Attributes column, and couldn't save.
Removed Attributes column, and still couldn't save. Then I disabled all viewer plugins, and was able to save.

As you can see, there is no consistency here - the only consistent thing is that I can always save with Opus closed ...

I installed 10.0.1.1, but still have the same saving problems with big tiffs.
tiff_max_doc_metadata is set to 64.
As I've mentioned before, Windows Explorer handles this without any problems ...