Error when copying to android phone

I found this errors recently in my PC when I was copying files from internal ssd to android phone,I get these messages sometimes only,Dopus doesn't finish the copying fully,in file explorer it's normal.They are as follows :



Please see here for suggestions:

I read your faq and as written in faq,what I came to know is when the "mtp_enable = is set to true" I get these error messages in latest DO beta,with android 12(which is the latest right now) and I also running latest windows 10(as said in the faq to check in latest windows).Don't want ftp to use because of it's slowness.

What happens with mtp_enable = false?

Now when i tested after setting "mtp_enable to false" and then,copying should not be considered because the copying is not done by DO,whereas in File explorer it doesn't show these error's

I'm not sure what you mean. Does it work or not?

to say properly when setting mtp_enable to false,because file explorer does the copying and it doesn't show error's and it(copying) should not be taken into account if mtp_enable is set to false because the copying is not done by DO.As I said above the errors are shown when mtp_enable is set to true in which DO does the copying.

So it works?

Low-level details of exactly how the copy is performed should not matter, unless there is some other problem you haven't mentioned yet.

Just you were about to reply I've edited my previous post please read it again and it doesn't work when DO is involved because the copying fails in between and Retry also doesn't work.

Have you tried it? I use mostly Google and Samsung phones and have never seen significant speed advantages of using MTP. On the contrary, factoring in all the hassles that come with MTP it was slower.

A quick test with an A52s showed transfer speeds of 24 and 28 MB/s for FTP and MTP.

yes,speed is the reason I use mtp,tried using 2 apps from play store but speed in ftp didn't crossed 1.5 MB/s and please tell me apps which you used for ftp in play store

1.5 MB/s is really a bit slow :frowning:

I have used Solid Explorer for years. Back in the day, I tried a few other apps, but I haven't tested anything recently.

But you can solve that by changing the setting I mentioned, correct?

Why should I use window's copying because it doesn't has the best features which are in DO's copy window.It's solved when windows does the copying,and not by opus,so there is an issue in DO.

I have very limited experience with this, but FTP server Pro seems to work.

please fix this

You just need to change the option I mentioned, or use FTP. There are already solutions to the problem you're seeing.