Explorer Replacement oddity

Latest DOpus works fine on desktop PC (always has done), currently on Win 7 Home Premium, and I have it in Explorer replacement mode. Same on my personal laptop. Always start it at login, and usually access it via Windows+E. I have AutoHotkey running, which intercepts some other Windows+ but not "E" and everything's just fine.

Just had to rebuild my laptop... fresh install of Win7HP, plus all the updates. Reinstall DOpus, set Explorer Replacement, start at logon etc., etc. Now, Windows+E persists in bringing up Windows Explorer, not DOpus. Double click on Desktop does bring up DOpus. Copied the desktop PC config across: same result. AutoHotkey not running on this machine (yet).

JOOI tried temporarily installing DOpus on another laptop with a relatively fresh Win7HP installation: same result!

Any ideas? My fingers just automatically go Windows+E...


If you create a new, empty folder on the desktop, what happens when you double-click that?

What is Preferences / Launching Opus / Explorer Replacement set to?

Double click new folder brings up DOpus Lister (as per main PC)

Pref/Launch/Explorer replacement set to "Replace Explorer for all folders" (does same non Windows+E behavior if set to the recommended one, too).


I'm not really sure why that would be, in that case.

Win+E is a Windows hotkey which essentially causes the My Computer folder to be double-clicked. (Possibly after searching for any existing windows showing the folder, but it doesn't seem like it from my tests.) That in turn usually opens the folder in Opus if Opus is set as the default file manager.

There are a few ways that could be blocked or configured not to happen, but not usually when it's working OK for other folders, and set to "Replace Explorer for all folders".

It's possible something (e.g. a security product) is blocking some of the Explorer Replacement hooks that Opus uses to divert folders to itself, and that it's a hook that's used in the Win+E case but not others. It could also be something else is intercepting Win+E and making it do things slightly differently.

You can sometimes create a Win+E global hotkey within Opus (Settings > Customize Toolbars > Keys), but it doesn't always work as the operating system tends to trap that particular key at a very low level.

Using another hotkey is often the easiest solution, if you can get used to it.

Thanks... I'll continue fiddling...