Explorer replacement problem : folders now open in Explorer

Hi,

I've been using Opus 10 in Explorer Replacement mode for a while on W7/64. A few days ago, a problem occured, and it's not working anymore.

Symptoms :

  • When double-clicking on a folder or a folder shortcut on the desktop, Explorer opens (instead of Opus)
  • When right-clicking / "Open in Directory Opus" on the same folder : Opus opens
  • Using Windows+E hotkey opens Opus
  • When third-party apps open a folder, it opens in Opus
    => The problem is only for double-clicks on the desktop, which always open Explorer. In all other cases, Opus opens.

Opus Preferences :
Replace Explorer for all folders containing files (recommended)

What I did :

  • disable / re-enable / change Explorer replacement settings in Preferences : no change
  • upgraded to v11 : no change
  • uninstall/reinstall Opus 11 : no change
  • restore configuration from previous backup : no change
  • Check DopusRT in HKCU/Run : OK
  • check ShellExecuteHook entries in the registry : OK ({3CF9ECE0-1A9F-11D2-8C73-00C06C2005DE} and {EE761688-C137-4b04-8FAB-3C9CDF0886F0}, nothing else)
  • check HKR/Folder and HKR/Directory : some entries were messed/missing. I tried to re-create them (exporting .reg from another Opus running on another PC) : no change
  • scan for viruses/malware (McAfee, MalwareBytes, ADWCleaner) : nothing found
  • search for third-party software with "Autoruns" from Sysinternals/Mark Russinovitch : nothing found. Removed suspicious/unused things, but no change with Opus

How dit it happen :
I was working on the computer. Then I noticed strange behaviors related to file types/default applications :

  • folders opened in Explorer and not in Opus
  • .txt files opened in Windows Notepad (and not in Notepad++, which was my previous default editor for text files)
  • Firefox said it was not the default web browser (but it was). Even when clicking on the "make FF my default browser", after restarting, it said again it was not the default browser

Then, I am conviced this is not really an Opus problem, but is merely related to the way Windows handles file types and default applications. Something may have been messed there.

I managed to solve the .TXT and Firefox problems, but the Opus problem is still here.

Any idea about how to solve that ?

Thank you in advance. Kind regards from a very old Opus user on Amiga :wink:

If you run my FileTypeDiag tool and just click Save (don't enter any extension), it will make a text dump of most of the registry settings involved in folder opening.

Post the results and I'll compare against a working system with the same version of Windows and see if anything stands out as a possible cause.

Here's the dump.
Opus FileTypeDiag Folders.txt (283 KB)

Something seems up with your registry or login session, since you have this default value:

HKCU\Software\Classes\Folder\shell: "" is REG_SZ: "openindopus"

But you are missing this one:

HKCR\Folder\shell: "" is REG_SZ: "openindopus"

The HKEY_CLASSES_ROOT (HKCR) branch should give you a merged view of what's under Software\Classes for HKEY_LOCAL_MACHINE (HKLM) and HKEY_CURRENT_USER (HKCU) but does not appear to be doing so on your system. The value in HKCU isn't showing up in HKCR like it's supposed to.

That may also explain the other problems you were seeing.

You might be able to fix this particular problem by creating a similar default value under HKEY_LOCAL_MACHINE.

i.e. HKLM\Folder\shell: "" is REG_SZ: "openindopus"

But unless you can work out what's happened to the registry in general and fix the underlying cause, I would expect a lot more problems with filetypes and COM components on that machine (or possibly with that user account/profile, not the whole machine, depending on where the HKCR merge is going wrong).

Do you have a System Restore point in Windows that predates the problem?

That can be an easy and danger free (it is reversible) easy repair.

Maybe you tried it already. I can see no mention of it. Then again, you seem to have tried so many things that older restore points may have fallen off the cliff.

Hi,

Thank you for your answers.

Leo, you were right about a lot more small problems on the machine. As you guessed, they were related to that specific user profile. I tried to create another profile, and all was working perfectly. Anyway, having to reconfigure my whole profile, with dozens of apps and settings, was not an acceptable workaround for me; then I continued the troubleshooting process.

The Windows Event Log (where I should have looked before) gave me an obvious error : 1542 - User Profile Service -Windows can not load the class registry file (File not found). This explains most of the symptoms, but not the cause, because that file is where it should be (%userprofile%\AppData\Local\Microsoft\Windows\UsrClass.dat)

Other strange behaviors were about small apps not finding their previous files and/or settings.

Then, I noticed some local environment variables, such as %APPDATA%, were not set on my system ! That was the reason why lots of software did not find their files/settings.

A quick Google search showed me this variable (and other default paths : Desktop, Downloads, History, My Music, etc... ) should be defined here :
HKCU / Software / Microsoft / Windows / CurrrentVersion / Explorer / User Shell Folders

Bingo ! The "User Shell Folders" key is missing on my system !!!

I exported it from another Windows 7 machine, and I imported it here. Problem solved. All is working perfectly.

Nota : According to Event Log, the "User Shell Folder" disappeared on Sunday Morning (3 days ago). I don't remember what I was doing exactly. Don't ask me why / how this registry key disappeared !!!
Nota2 : This is not a problem with Opus at all; anyway, maybe the solution will be helpful for other people.

Thank you again. Now let's discover the new features of Opus v11 :slight_smile: