Extension not stripped when using {file|escregexp|noext}

I'm using DO

I tested {file|escregexp|noext} to see if that did the trick for me as part of a regex, but I noticed that it doesn't seem to strip the extension, as
the help says it should on the page "Codes for passing filenames", regarding escregexp.
It doesn't even do it for a singleextension file, i.e "test.jpg" becomes "test.jpg", not "test".
The order doesn't seem to matter, only that "escregexp" is present.

After I couldn't get it to work, I tried using {dlgstring} to show what it actually contained, and below are the results.
With the file "test.part1.rar" selected
{file|noext} = "test"
{file|escwild|noext} = "test.part1"
{file|escregexp|noext} = "test.part1.rar".

As I see it, only one of those should be correct in all cases, although I'm not sure which, although if it should match the documentation then it should've returned "test" (or test.part1, test.part1)
in all cases.
Which direction does it actually parse the flags/parameters (left->right, right->left)?

What I originally was looking for was a way to select all parts of the current .rar file(s), without also selecting files with similar names.
However, .partX seems to be in the filename part (or not), so I'm a bit stumped.
The filename might contain brackets etc, so to use it in a regex I would need to escape them.

Say you have these files

and test.part1.rar is selected, then I want all test.partX.rar selected, and nothing else.

If both test.part1.rar and test1.part1.rar is selected, then I would want it to select the parts of both.

If the {file|escregexp|noext} really worked and returned the base (without .partX), then I could've used something like:
SELECT REGEXP "{file|escregexp|noext}.part\d+.rar", or something similar.

It looks like a bug, thanks for the report.

Actually, it seems there is a couple..
In addition to the escregexp, it seems like ext/noext has special considerations for .partX.rar filenames, and based on what {file|ext} returns (.part1.rar), only
{file|noext} returns the correct value of those I listed above.

In case anyone wonders if this is fixed in 10.5 or not.
Nope, same return values as above.

This was too late to change in 10.5.

This should be fixed now, for the next version. (Edit: Which is out now.)

Nice, now it works.

I have moved the new question into a thread of its own: Select {file$} runs even if nothing is selected

I use DO 11.1 x64.
I noticed that this regex no longer works in DO 11 (it worked in DO10 after the above was fixed):
SELECT REGEXP "^{file$|escregexp|noext}.part\d{1,3}.rar$"

In DO11 the regex the above builds is:

It seems this issue has returned partly in DO11, but with some differences (old bug value in parenthesis).
Which of these is actually correct?

{file$|noext}=test.part1 (test)
{file$|escwild|noext}=test (test.part1)
{file$|escregexp|noext}=test.part1 (test.part1.rar)

Btw, using escwild or escregexp in {file$|ext} causes it to not return an extension at all with both ext and ext2.

The button below lists values for the above, just select a file named test.part1.rar and you'll probably get same as above.
I haven't found a proper dialogbox (without resorting to scripting), hence I used dlgstring.

<?xml version="1.0"?> <button backcol="none" display="label" textcol="none"> <label>New Button</label> <icon1>#newcommand</icon1> <function type="normal"> <instruction>@nodeselect </instruction> <instruction>@set test1=file, noext = {file$|noext}\nfile, escwild, noext = {file$|escwild|noext}\nfile, escregexp, noext = {file$|escregexp|noext}\n\n</instruction> <instruction>@set test2=file, ext = {file$|ext}\nfile, escwild, ext = {file$|escwild|ext}\nfile, escregexp, ext = {file$|escregexp|ext}\n\n</instruction> <instruction>@set test3=file, ext2 = {file$|ext2}\nfile, escwild, ext2 = {file$|escwild|ext2}\nfile, escregexp, ext2 = {file$|escregexp|ext2}\n</instruction> <instruction /> <instruction>{dlgstring|{$test1}{$test2}{$test3}}</instruction> </function> </button>

Btw, Alt+Esc (Undo), Shift+Ins (Paste), Ctrl+Ins (Copy), Shift+Del (Cut) don't seem to work in the editor.
Alt+Esc seems to work as undo in just about any windows app, and the others are still rather commonplace.