Extract HERE not working

I'm having a problem with the Extract button.

If I have a .zip file or a folder and use the button, it extracts all underlying files to the destination lister (good). If I add a Delete QUIET command at the end, it deletes the file/folder when it's done (very good). But what I really want is to extract the file/folder to the current directory in the current lister... so I changed it to this:


I've had this button on my toolbar for years and it worked fine... but hasn't worked at all during the past few upgrades (I'm on Why is the HERE command causing it to fail? This is the error I'm getting:

Work fine for me...

I have the same problem. Copy EXTRACT HERE worked fine, then broke sometime within the past couple updates. (currently running

I even tried setting WHENEXISTS=rename in hopes of trying to get around that dialog error, but no go.

It's still not working for me either. I'll have to test some more and report back.

"Activate Opus ZIP file handling" are enabled in Prefs ?

yes, it's enabled. However, in my case at least, this problem is with copying FOLDERS, not ZIP archives.

I don't think Copy EXTRACT has ever done anything with folders. The EXTRACT argument is for dealing with archives (zip and rar files) so if it's only failing on folders then that's normal.

(Later edit: Turns out I was wrong and it used to work, and now works again in Opus

If you want to copy/move the contents of selected folders out of the folders then there are different commands which will do that. (Some examples are in the Buttons & Toolbars forum, as I remember.)

Per the Dopus documentation for COPY:

"This option is mainly used for extracting files from ZIP files, but also operates on folders"

Like we both said, this used to work just fine until a couple releases ago.

Here is the error I get when I have select a folder called test subfolder and then click on the Extract button. The parent folder is "test".

Why would it work? You cannot copy a file into itself which is what your command would do.

It's not. I have a c:\test\test subfolder arrangement with a .txt file in the subfolder. There are no other folders or documents in the c:\test folder. I want it to extract the subfolder and move all of its documents into the c:\test parent folder, then delete the subfolder. That's what has happened in the past.

Perhaps you should file a bug report then. Let's see what GPSoftware can make of it.

will do. i could tolerate having another button do this but would prefer to just use the Extract one.

OK, I just filed the bug report with gp. I was trying to determine if there was something I was doing wrong, or this was a genuine, newly introduced bug. Given that it used to work, the docs say it should work, and the lack of "no, stupid, do it THIS way" forum response, this now seems worthy of reporting as a bug.

BTW, I use @dironly @nofilenamequoting Copy MOVE "{f!}\." TO "{f!|..}" in the interim, but it lacks the ability to extract from archives. The advantage of COPY EXTRACT HERE was that one button could extract folders AND archives.

Personally I only use Copy EXTRACT=sub HERE for zip files otherwise you can end up with a huge mess in a download folder. :slight_smile:

Given that, I'd have to use two buttons for your scenario.

1 Like

Actually I usually use this "defolder" command AFTER I've extracted a ZIP file into a separate folder. First I extract each ZIP into it's own sub folder, but if I find there's only ONE file in the subfolder, I "defolder" it. Having subfolders with only one file in them annoys me. :slight_smile:

thanks selmo

Each to their own. :slight_smile:

fixed in

thanks GP