Field width?

Is there any way to specify the exact width of a field? If I have two fields next to each other, it seems I can only get them to be of equal size, or to get one field very wide while the other is too narrow to see anything inside it.

Not sure which fields you're referring to... toolbar fields or lister file display column fields? You should be able to control the widths of both. I have a feeling you're talking about toolbar fields and are experimenting with the Full Width option you get when in Customize mode and you click RMB on one of the actual field boxes...

If so, then for toolbar fields stay in Customize mode and deselect the Full Width option for both the fields you want to adjust... when you've done this you should see shaded in boxes in both right hand corners of the field 'box'. This indicates you can drag the fields rightmost edge to the position on the toolbar you want it to stop at. That should be it.

You are correct :slight_smile:

Oh wow, perfect! That's exactly what I needed - thanks

np... for future reference, also be aware that there are some items on the toolbar that take up less space while in customize mode than they do while in normal usage. Specifically, when you have buttons/fields set to show labels to the left or right... this can make it a bit of a chore to tweak the field widths juuuust the way you want them in order to match up to other elements of the UI - like the folder tree for example.

Is there any way to get the spacer to automatically fill the empty space on a toolbar? Kind of like the "Flexible Space" available in the Firefox toolbar?

If you want any field (including the Spacer) to consume all remaining available toolbar space, right-click on it in Customize mode and enable the Full Width option. If you do this to more than one field on the same toolbar, all fields with this option enabled divide any remaining available toolbar space equally between them.


Hm. The spacer works as you describe only if the toolbar is hosted inside the lister window. The toolbar I'm working with is docked to the top edge of my screen, and the spacer doesn't seem to work the same way there.

Confirmed. I wonder if that is by design or not? I have filed a report on this.

All right - thanks