File-display scrolling slow with selected files


I have say 200 files in a directory. Scrolling arond is smooth. If i select 50 files from the 200, scrolling around gets sluggish when the display gets to the selected files while scrolling. Is this an indication that i need to upgrade my PC?

I have a Radeon HD 5770, Amd Athlon II X4, 4 gigs of corsair ram on 1333 speed. Win 10 Pro latest update, Dopus latest beta. System on SSD, files are on hard drive.

I have label filters, 5 columns (none scripted), custom sorting by labels column, custom colored file-display background and file background (no images, only plain custom colors), details view. I know if i set the file background to transparent, the scrolling stays smooth. Can anyone give me any idea? All viewers are turned off in Dopus. I also noticed that if i turn off relative-graphs, the scrolling gets a bit smoother. Obviously the more stuff i have on screen, the more the cpu needs to work, but do you think its a hardware issue, or maybe Opus does something thats not optimal when displaying things? I would like to know your opinion on this please!

Thank you!

Drawing selected items vs non-selected items should not have much of a difference in performance unless something is wrong with the system, or the real problem is somewhere else.

Is the same true in Explorer?

Have you installed graphics drivers since the recent large Windows update (which can trash your graphics drivers and performance until new ones are installed)?

Scrolling in Windows Explorer is smooth no matter how many files are selected. And i let windows10 to update graphics drivers automatically. Its an older GPU and there arent really new drivers for it. I will try to install a driver from the maker. By the way this is also the case on a Win7 laptop. Its even older. Same thing happens. If im scrolling in lets say "System32" folder (with lotsa files), scrolling is smooth, then i select files and scrolling becomes laggy when the selected items are on display. Can a toolbar have any impact on this?

And if i set "Selected file background" to RGB:000000, or transparent, the lag disappears (even on the old laptop). But if i enter RGB:000100, putting only 1 green into it, it becomes laggy.

Thank you for the ideas! Although i dont think changing gpu driver will make an impact, because im playing games like Warframe with it, but i will still try it.

Oh and im using the high contrast theme with the minimal possible animations and without transparency, while occasionally changing to default theme. It makes no difference.

If i turn on "use visual style to draw..." in Dopus, the lag also disappears, but only with the default Windows theme. High contrast still lags with option on or off.

I just noticed that I am having the same problem as well.

If I set the color for "Selected background" for "Files and Folders" to anything but white, lister pane display scrolling lags horribly when selected files are in view, and resumes normal speed once those files are scrolled out of view. This happens with both the mouse scroll wheel or the lister scrollbar. Additionally, this does not happen in Windows Explorer. The folder scrolls fine.

I've tried this with folders containing +5000 files all the way down to ~150 files and the behavior is the same.

I don't ever recall experiencing this problem before. I did do a major system update a couple of days ago installing every new driver for my system from Dell, including a new GeForce driver. I'm going to try to rollback the driver and see what happens. I'll repost when I have more.


Could you post a screenshot of how your window looks with some selected files displayed?

Normally, the selected background color is not even used as the Windows visual style overrides it by default on modern versions of Windows.

This issue came up again today ( Laggy scrolling in Lister ) and I think we've got to the bottom of it now. It's probably what you were seeing as well.

We've made some code changes for the next beta (12.16.3) which fix the underlying problem.

In the meantime, if you turn off Preferences / File Display Modes / Details / Vertical for now, you should see a big improvement, but once the new version is out you should be able to turn it on without the big performance hit.

1 Like