File filter in flat view bug

Please confirm that it's not just me :slight_smile:

  1. Navigate to a folder with subfolders.
  2. Enter a file filter (ex.: *.png)
  3. Switch to flat view (Set FLATVIEW=On,MixedNoFolders)

At this time, subfolders are displayed in the files panel along with the matching files.

  1. Refresh (Go REFRESH)

The subfolders are then removed and the flat view display is correct.


It's not just you. If you perform the Flat View before the filter, it behaves as you would expect.

Regards, AB

Thanks for the confirmation. I'll change the way I use this functionality (although the performance really suffers with large numbers of files - filter first is significantly quicker).

I haven't tried it, but I'm pretty sure that as a temporary bypass you could define a button to combine FlatView and Refresh into a single click operation.

Regards, AB

I tried that first but received even more bizarre results. For some reason, the operations must be done using separate buttons.

What I would really like is to have a entry box for a filter view filter. Just enter the filter criteria and a flat view would be shown displaying just the requested files. But, I believe you cannot create or customize the entry boxes (such as file filter).

Set FLATVIEW=On,MixedNoFolders Go REFRESH=source
Worked for me. There is a flash of folders but then the Refresh kicks in.

Regards, AB

I tried combining these buttons again, but I do not get consistent behavior. Usually, upon hitting custom button, I see the results for a split second (incorrect as folders are displayed) then. immediately, the results are completely cleared. I have to hit the button, sometimes up to 4 times, before the results are displayed correctly.

Figured it out!

I modified the filter to include the args option of: files

I tried this after reading this faq: ... filterattr

Thanks for the help

Confirmed. It looks like any folders which are hidden when you enter FlatView MixedNoFolders will become unhidden. In other words, the folders' visibility is toggled instead of being set to off.

I've reported it to GPSoftware.