GP SoftwareTwitter
Opus FAQsManualCommandsObjects

File Preview Settings?


#1

I'm not sure that I'm using the correct syntax, but I think it's called a file preview... For example, when I hover my pointer over a text file, a pop-up windows appears with information as to Type:, Date Modified:, Size:, and then a sort of preview window ( within that same pop-up window ) that shows some of the text in a small font size.

Anyways, what I'm wondering is there a way to add additional information to that file preview pop-up window? In addition to the Type:, Date Modified: and Size: , I'd also like to include the Attributes information, whether it's a read-only file, and whether or not it's a hidden file. I know that we can see hidden files within Opus, if we have that setting enabled, but like I said, I'd like a quick way to see the attributes in that preview window. My only way to see those Attributes now is to right-click the file, go to Properties, and then have a look-see at the bottom of that resulting window.

So, is it possible to do what I'd like to see within Opus? A quick hover of the mouse pointer is much more efficient than having to right-click, choose Properties, and then have a look. TIA !!


#2

Filetype infotips is what you're looking for:

gpsoft.com.au/help/opus11/i ... fo_Tip.htm

Note that you usually edit the "all files" item and Images etc. file type groups in the top two sections of the filetypes list, not individual types like .jpg and .gif.


#3

Thank you, leo !! I had to do a bit of digging, but I finally figured it out. On my way to getting it done, I came across a bit of information pertaining to the {thumbnail} command. The only thing I found was that I could specify four options, the numbers 0-3 for borders and such. Is there a command to set the size of the thumbnail that is displayed in the infotip?


#4

Infotip thumbnails use the same size as the lister's thumbnails. (Set under Preferences / File Display Modes / Thumbnails unless you've overridden the size for a particular lister, e.g. by dragging the thumbnail size slider.)


#5

Many thanks, once again!!!!!


#6

Well, I seem to have run into a small problem. The Prefs setting for the thumbnail will only let me set size to 256 x 256, and I have make square checked. Is that the largest value I can enter, or is there something I need to change elsewhere in order to increase that 256 size to 512?


#7

Preferences / Miscellaneous / Advanced: max_thumbnail_size lets you go above 256x256 (note that increasing it means more time/memory/disk is used for caching, since larger thumbnails are stored in the cache).


#8

Still having problems. I set max size to 512 and max memory to 200mb. That setting sticks after a re-start of Opus. But the actual thumbnail setting will not let me increase it to 512 x 512. Well, it lets me change it, and I click Apply, but when I go back to double-check the Prefs, the setting is back to 256. And the slider only goes up to 256 also, even though the Misc / Advanced setting still holds the 512 value...


#9

Forgot to mention that I have 12 GB of DDR3 memory, so I don't believe that to be the issue...


#10

Fully exit Opus (via File / Exit Directory Opus), then restart it and see if you can change it now.


#11

Ahhh, you were on the right track. I did as you said, but it still would not stick. Then I did as you said, but this time, I checked Task Manager, and it showed that Directory Opus was still running something, so I ended that process, and once again started Opus. And, at last, the 512 setting sticks, and I get to see glorious thumbnails that I don't have to squint at.. Many, many thanks!!


#12

Did you use File / Exit Directory Opus, or just close the window?


#13

I clicked on File / then at the very bottom, Close. I do not have an Exit, but I assume it's the same... Running the very latest beta that you just released...


#14

I just double checked, and the same thing happens. When I click on File/Close, in the task manager there is still dopus.exe running in the background, with a PID of 5352, and using 28K of memory.. Don't know why, but it is...


#15

It sounds like you don't have the default toolbars. All you're doing is closing the lister window, not the whole process.

See the FAQ Leo linked to for more information.


#16

You are correct, in fact, I don't run any of the default toolbars. All of them have been customized for my particular needs. I dislike desktop icons, so I have toolbars with buttons to each and every program I run. I don't even use the Start Menu, not even to shut my computer down, or put it to Sleep. I have custom buttons in Opus that does that. It's not a problem for me, to be honest. It was just a small issue in this one instance. I have Opus running always, when my computer is on, so I never have the issue of having to end the process in Task Manager.

I guess you could pretty much say that Opus is my wallpaper.. :slight_smile: