File selection when clicking to activate Lister - strange behavior

Hi,

I'm experiencing unexpected behavior regarding the File Displays -> Mouse -> Allow file selection when clicking to activate Lister setting. Maybe I'm not understanding something, or maybe there is a bug. I don't recall it being like this before, but it could have something to do with other settings in my lister, which recently changed quite a bit.

When I have the setting turned on (checked) and the lister is out of focus...
[ul]
[li]In List view, clicking on the file list (left-click, right-click, double-click) does nothing. Not even the window activates. Only clicking in the white space activates the lister and allows the selection to change. This is the behavior that is most strange to me.[/li]
[li]In Details view, the first click activates the lister, but if that click is on a file, the file is not selected until you click again. (Though clicking on white space as the first click deselects the selection.) This seems like it should be the behavior for when the setting is unchecked. No?[/li][/ul]
When I have the setting turned off (unchecked) and the lister is out of focus...
[ul]
[li]In List or Details view, the first click reactivates the lister. If the tree pane was in focus, the first click in the file display will be eaten. On the third click, I can change selection. If the file list was in focus when the lister gets reactivated, then it only takes two clicks to change the selection. This is the same behavior as the second scenario described, except that clicking in white space does not initially deselect the selection. I guess this setting most closely mirrors what I would expect to see, with the exception of the second click being eaten because the tree was in focus.[/li][/ul]
I'm running Windows 10.

I have discovered that turning on the File Displays -> Mouse -> "Allow file selection when clicking to switch source/destination state" fixes the issue. Turning off that setting was the cause of the strange behavior I referred to. It seems like a bug to me, or maybe I just don't understand the design.

To recap, the behavior that was strangest to me was, in list view, clicking (or double-clicking) on any files in the file display, after returning from the lister being out of focus, does nothing.

I haven't been able to reproduce anything unexpected in Opus 11.16.2 / Windows 10.

It may be down to a combination of other settings, although I tried the others on the same Mouse preferences page which were likely to interact with the setting in question and did not find any combinations that misbehaved.

It could also be an interaction with other tools or mouse drivers/settings on the system.

Hmm.

I'm running Build 5738 (11.16 x64).

What happens in this situation?

  1. Go to Preferences -> File Displays -> Mouse
  2. Check #1, #3, #7. Uncheck the others. Click OK.
  3. Set single display to list view
  4. Select multiple files
  5. Click on another window to remove focus
  6. Back in Opus, click one of the file displays

For me, the selection doesn't change. In fact, the window doesn't even come back into focus until I click somewhere in the empty space (or some other window chrome). All clicks to the filenames in the listing are lost.

It might be a confluence with other settings. I can't tell which.

Looks like that's how DO works - makes no different if you are in Power Mode or Details or any other - your (my) selection gets deselected every time I use mouse to select another file (or I click empty background in the lister).
The only exception to this (selection will stay) is in Power Mode but you need to use keyboard to navigate (if you use mouse selection will be gone)

You misunderstand. In this scenario, clicking a file item in the lister when Opus has lost focus does nothing. I expect focus to be returned to the window and the file you click on to be selected. But all clicks on any file item are eaten.

[quote="soja"]Hmm.

I'm running Build 5738 (11.16 x64).

What happens in this situation?

  1. Go to Preferences -> File Displays -> Mouse
  2. Check #1, #3, #7. Uncheck the others. Click OK.
  3. Set single display to list view
  4. Select multiple files
  5. Click on another window to remove focus
  6. Back in Opus, click one of the file displays

For me, the selection doesn't change. In fact, the window doesn't even come back into focus until I click somewhere in the empty space (or some other window chrome). All clicks to the filenames in the listing are lost.

It might be a confluence with other settings. I can't tell which.[/quote]

Thanks for these details. I've reproduced the problem now and we have a fix on the way for a future Opus 11 update.

Aha! Thank you.