GP SoftwareTwitter
Opus FAQsManualCommandsObjects

File viewer Shrinks Image when previewing while logged in remotely

bug-report

#1

This happens when I log in remotely from my personal computer to my work computer and only happens when I open a new dopus window. If I leave a dopus window open with the preview pane on at work (for example something I was working on the prior day and I just left up on my screen) then remote in, the preview pane works fine on my home pc. However, when logged in remotely, if I close that window upon reopening the previewer glitches and shrinks the doc image. When this happens, in order to reset the glitch on my work computer I have to reboot the system. I apologize in advance if this is sounds complicated but I wasnt sure how to explain it. Hope the picture helps! Thank you!


#2
  1. Is the same true in File Explorer?

  2. Which versions of Windows are the client and server?

  3. Which DPI scaling amounts are both machines configured to use?

  4. Does it only happen with PDF documents and not, say, RTF documents?

It may be a bug in the PDF preview handler rather than Opus. (Looks like you're using Adobe Reader.)

Depending on which document types it affects, it may also be possible to prevent the problem using the DPI compatibility settings. We can go into that based on the answers to the questions here.


#3

Hi Leo,

  1. Nope, File Explorer works fine. Previewer shows the full image.

  2. Both Windows 10.

  3. I'm not sure how to check the DPI settings. Could you please advise how to determine that on both machines?

  4. It does not seem to happen with word or RTF's.

Thank you for your help!


#4

Is File Explorer using the same viewer for PDF files? If it doesn't happen with other file types then it's probably just a bug in the PDF viewer you're using.


#5

I've never set PDF viewer options in opus so I'm going to assume they do. In file explorer I use Adobe Acrobat DC.


#6

I just found the default settings pane for opus and the default setting for the viewer is Adobe PDF for Vista 32 bit... I have the most recent version of Adobe Acrobat DC on my machine. How can I change the default viewer in Opus to reflect a more recent version of Adobe?


#7

Update: I installed Foxit thinking that maybe it was a bug adobe reader as you suggested and logged in from the remote computer to check if pdf viewer was working but im still having the same issue in opus. File explorer works fine.


#8

"Adobe PDF for Vista" is still the name Adobe give their preview handler even in new versions. (Adobe aren't very on the ball.)

After installing Foxit, is it now being used to display PDFs in Opus?


#9

Yes its now using foxit, unfortunately still having the same issue :confused:


#10
  1. You definitely don't see the same issue with other viewers like Word and Excel, if you do the same thing with them?

  2. If you fully exit Opus (via File / Exit Directory Opus) and re-launch it, does the problem go away?


#11
  1. From what I tested yesterday I did not experience any issues with other viewers.

  2. In order for the problem to go away I have to do a full reboot of the main computer.


#12

Hi Leo,

I just wanted to follow up to see if you found any bugs or anything?


#13

It doesn't make sense that it only happens with some viewers and not others, unless the problem is in the viewers themselves (i.e. Adobe Reader in this case).

If you want us to look at this in more detail, we can, but you need to link your account.


#14

Sure, how..?


#15

Just kidding, figured it out. You've done a great job with the site. Considering the problem happens when I log in remotely, how would you suggest I show you?


#16

We'll try to reproduce it locally, as I think we should be able to set up the same kind of scenario. Will let you know here if we have trouble reproducing it.


#17

Great sounds perfect! thank you for going out of your way to help!