Files can not be deleted

every time i delete any file it still appears in my folder and only gone if I move to another folder and come back to same folder where I store my files. How can I solve this issue?

If you quit Opus fully (File -> Exit Directory Opus) and run it again, does it still happen?

I tried and not solved.

Does this happen on your local C drive or only on a particular device?

Is it a network drive? What's at the other end of it? Windows, or something else?

its on the local D drive.
its not a network drive.
Windows 10

That is strange. Please try the suggestions here:

I tried all steps and still same issue.

Please show us the debug output.

Also: Do you have Kaspersky installed?

Yes. Kaspersky installed.

I tried to upload the debug output file but I couldn't.

The FAQ mentions a problem where Kaspersky completely breaks change notification in Windows (unless the process is whitelisted). You may be seeing a result of that issue.

Please try whitelisting dopus.exe to see if it works. Instructions are in the post which the FAQ links to. If that fixes things, please complain to Kaspersky as they seem to have been ignoring this problem for years and it affects a lot more than just Opus.

More detail please. What went wrong? Was there an error message? Did you zip up the debug output, or try to attach it as-is, or try to paste it into a message? (Zipping is best, if it's a large amount of text.) (770.4 KB)

please find attached debugfile. Appreciate if you could help me solving the issue.

Have you tried whitelisting Opus in Kaspersky? We know for sure that Kaspersky can break the notification system in Windows, so I would try that.

In the debug log you sent, which file (full path) was deleted, so we know what to look for?

How can I do whitelisting Opus in Kaspersky?

"Instructions are in the post which the FAQ links to."

The FAQ: Changes to folders are not being detected

The post the FAQ links to:

In a word, Kaspersky.

To elaborate, I thought I had already tested removing KAS but maybe I didn't reboot after or something, and it's odd because it is also installed on a computer at work that does not present the problem--same version of KAS.

Note that this version is a corporate version, which installs:

Kaspersky Endpoint Security 10 for Windows and Kaspersky Security Center Network Agent

A central policy is pushed out to each client computer and enforced. It has control over settings, like trusted applications (a whitelist). When IT pushed out a whitelist entry for my specific application, it fixed the problem.

Note that there are several checkboxes to select for each trusted application entry. This fix only needed one of them.

Under Settings | Anti-Virus protected | Exclusions and trusted applications | Settings, there is a list that can be added to.

Do not scan opened files X Do not monitor application activity Do not inherit restrictions of the parent process (application) Do not monitor child application activity Allow interaction with application interface Do not scan network traffic

Honourable mention must go to my co-worker, Arti Chauhan, who suggested more than once that KAS might be the problem. I thought I had fully tested when I guess I hadn't.