GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Files pane only showing "Primary" for a connected Garmin Fenix

This query is sparked off by having just acquired a Farmin Fenix 5s Plus watch and not being able to explore its contents from the folders pane. When connected, it does not get a drive letter. It appears in the folders pane as "fenix 5S Plus". Under that is a device called "Primary".

The "Primary" can be expanded in the folders pane to show sub folders such as "Garmin", but when such sub folders are selected in the folders pane, the files pane only ever shows the "Primary" icon. No folder contents are displayed. The device can only be explored by opening the device and its folders from the files pane.

Same for when an iPhone is connected. It appears as "Apple iPhone", and below that is an icon called "Internal Storage". The same issue occurs.

I initially thought this problem was particular to the Fenix, so I tried the iPhone as a test, knowing that it used to work ok, so this seems like a bug.

This is version 12.14 on Windows 10 Pro.

01

Some of the suggestions here are worth trying:

OK - just tried disabling mtp, and the folder contents now display, but as you implied, it uses windows explorer functionality. Not good!

However, I'm pretty sure that this wasn't an issue previously with the iPhone, implying that somethings changed at your end.

I'll go back to a previous image backup of my system and have a look.

..a quick update - just tried connecting the iPhone, and there is no way of seeing the contents at all, so that is actually worse than before!

02

What happens in File Explorer?

Strange - it's working now. That's a mystery...

01

Try navigating by double-clicking on folders in the file display rather than using the tree and see if it behaves differently.

That's how I have been doing it. It's the only way to view the folder contents.