Find - Advanced Filters

Hello:
I'm unable to get DOpus to find within the Document filters. I've setup the filter as: And Document Match Keywords manual

I've applied the keyword "manual" to a few test files. It doesn't find them.

Am I doing something incorrect?

Are the documents actually tagged with keywords?

Add the Documents->Keywords columns to your Opus lister and see if anything appears.

You're right.

I applied the Keywords column to the lister and nothing is showing.

The manner in which I've tried to apply the tags is through the file properties dialog on the Summary tab.

So, what do you think I'm doing wrong?

Thanks.

What type of documents are they (file extension) and are you definitely adding it to the 'Keyword' field and not some other like Comments (had to ask... trust but verify :slight_smile:)

Also... are you sure that it's not showing up in the column in the lister... it took mine a couple of seconds to appear after hitting refresh. Either way, I'd imagine that if you CAN'T see the Keyword in lister column... that should probably explain why it's not being found with a search. From here we figure out what is unique on your system about these files... I tried mdi, txt and rdp extensions and they showed up fine.

Interestingly... if I add the 'Keywords' column to a Windows Explorer window... I do NOT SEE the keywords...!!!

OK.

Well, I've applied the keywords into the keywords field. They do not show. Even after a refresh. I've exited DOpus and re-started -- no show.

I've applied the Subject and Comments to show in the lister; they are showing on some files; but not the keywords.

I've been playing with different files to see the results. A PDF file will not show from the Properties Summary. It will show from a direct save from Adobe.

In all cases the DOpus Find will do a ligitimate filter search, but not find anything.

I don't understand...

Are you using Opus 8 or Opus 9?

I use Windows XP Pro on a Dell Dimension 4600i, Pentium 4, 2.8 GHz, Directory Opus 9.0.

RE: trying to search for meta data with DOpus

Things I didn't understand:

  • the data is "file type" dependant
  • ITPC, EXIF data is for .JPG

Things I think I understand now:

  • DOpus can find the data within a search using the >Document feature; which is the Property Summary tab, but this info is separate from the imbedded ITPC, EXIF data

Nothing is very straight forward in computing is it?

Opus supports many of the EXIF tags for columns and searching. You'll find them under Pictures.

The two types of information are not consolidated because you could, for example, have a JPEG file which has an EXIF comment as well as a separate generic NTFS file comment.

Didn't think we were talking about either EXIF or ITPC before... so I'm assuming that when you were having problems finding/displaying 'Keywords' data, that this is still the case and that it was NTFS Keywords from the Properties->Summary tab... and not some other container specific 'Keywords' tag...? For instance, maybe you've got some apps installed that replace the property sheet handler for certain file types, and result in some other meta-data called 'Keywords' to be set when you edit them?