Find Command running very slowly since 12.7

I have use the command line below for some time now on 12.7 without any issues.
It loads a collection I created for my working files from many sources including libraries, network locations and external USB drives.
Up to 12.7 it would load all files from all locations in around 30sec (~85000 presently).
Any version after 12.7 has worked with the same script but incredibly slowly and effectively locks up Dopus until it has finished. This did not happen in prior versions and now takes at least 5 minutes or longer for the same result.

Here 'tis,


I'm not sure what has changed since 12.7. I tried looking through the resource centre but couldn't find anything specific.
Has anyone else come across this problem?

It's difficult to say much without a clearer version of the command. Are the network locations computer names, shares, folders below shares, etc.?

What's in the library? Which kinds of folders does it point to?

What kind of device is E:\?

Does the library or network paths point to any servers which are offline or unreachable? (That will cause huge slowdowns.)

Have you tried searching one path at a time to narrow down which one(s) are slow?

Have you gone back to 12.7 to confirm it is faster, and not something else which changed instead?

The command syntax is also incorrect, but maybe that was just to try to make it display correctly in the forum. See the help page linked above the post editor for information on how to format things on the forum.

Hi Leo, Thanks for responding.

I have edited the original post to show the actual drives and fix the formatting. Sorry about that!

The working library is a bunch of local and USB drives on the PC. The E: drive is an USB SDcard reader which was meant to be temporary but is attached all the time now.

The network drives are SMB shares and are always on and attached before I run the command.

It appears to slow down significantly at the point where the network drives are accessed. Previously the dialog would be on screen until just before it had read all the files but with 12.8 and above it is on screen roughly until it starts reading the network, disappears, and then the file count in the lister slowly increments for the next few minutes until it is finished. The resource monitor also show it writing to the .col file the whole time.

I have run 12.7 from it's release. I installed every new release up to about 12.12 hoping it would resolve itself but I alway have to drop back to 12.7 . Since then I try new releases sporadically without success and revert to 12.7.

BTW I have run Windows 7 the whole time. I am not planning on upgrading Windows 10 until I have some free time.


Try narrowing down the locations that are being searched in case a particular one is causing the slowdown.

We'd also need to see what your MATCH_FILES filter is defined as to have a clue what the find is actually doing here. If that is searching file contents then it's always going to be slow on a network drive, since network drives are slower in general and especially if you're reading the content of lots of files to search inside them (not just searching their names).


Definitely not searching contents. All I have done is limit the search to files only. Reading from local drives seems OK but network access has slowed down. It just seems that that part of the search is shuffled off to a different task/thread and nothing can happen until it is finished.

The change in behaviour only happens after 12.7.

I will try to do some testing with 12.20 but it will take some time. My day is 3/4 spent in DO and sometimes I sleep.

I've been using 12.7 for 2 years now and I finally got round to having a grumble about subsequent updates. I'll last a bit longer!


Thanks Leo, Stay Safe!