Flat View Ques

I'm new to DOpus, so my ques here are elementary...

When I select "Flat View" from a folder with several subfolders, I see a 'flash' of contents, that immediately disappear. The Status Bar does show (492 Hidden Items), so that's obviously the problem - but - I haven't selected Hide for anything - that I know of.

Why would files be hidden in Flat View and not otherwise?

Thanks
Al

Maybe you've got a filter set which hides folders? That will cause anything below those folders to be hidden in a flat view.

Check in Folder Options, or using the filter boxes explained in this FAQ, to see what you're hiding.

It could also be system/hidden files which are being hidden.

Also note that under Preferences, Folders, Folder Formats there is a special format for Flat View. If you've configured that to hide different files to your other formats then that will explain what's going on.

Leo,

I've looked through the FAQ's & Tutorial, and checked the Prefs/Folders/Folder Format. The Flat View does not show anything Hidden. I've tried this with the Flat View format Uncheck, with the same result.

I agree that this seems to be an issue of something being 'Hidden', but I'm not seeing a setting that indicates that 'Hide' has been selected.

Of course there ARE a lot of settings :slight_smile: I'll keep messing with it and will likely come across something.

Thanks
Al

Maybe a dumb question, but you're not selecting Flat View (Mixed No Folders) are you?

Jon,

I've been using "Grouped", though I can't say I know why "Mixed - Not Folders" would be a problem, since I don't normally display Folders in the File Lister.

Have also tried "Mixed", and have tried removing the Filter to Hide Folders in the File Lister. Same results - a 'flash' displaying the files, then reverts to the contents of the current folder.

Thanks
Al

I suspect your Flat View folder format (Preferences, Folders, Folder Formats, Flat View) is set to hide folders.

If you hide a folder in Flat View you won't see any of the files in it either.

When you change to Flat View the Flat View folder format will be used automatically (unless you've turned on the format lock or whatever).

Leo,

I did not have Folders Hidden in the Flat View Format, but I do/did have them hidden in my Folder Options/Filters. If I remove this filter, it works. Thought I'd already tried that - guess not!

Here's the point of confusion - Why does this filter affect "Mixed - No Folders" use of Flat View?

My preference is to use the Tree and not to use folders in the File List, since they take up too much space.

Thanks for helping me sort this out.

Al

Weird... seems to be some kind of handling conflict. To play around, I tried the following combos:

  • Set a Folder Options->Filters->Hide Filter->Folders: to * in order to hide folders in the file display like Al has done.
  • Clicked a folder in the folder tree that I know has several nested sub-dir paths.
  • Ran Set FLATVIEW=Toggle,Grouped and saw the same brief flicker of the sub-dir contents as Al which then disappeared. I also see the same effect if I run Set FLATVIEW=Toggle,MixedNoFolders...
  • However, for some weird reason if I run Set FLATVIEW=Toggle,MixedNoFolders FIRST, and then immediately run Set FLATVIEW=Toggle,Grouped then I actually DO see the sub-folders, but NOT their contents (files)???

Weird...