Focus on 'Delete", but using ENTER does something different

In V13 it's not possible to use the Enter key to choose the active menu item (indicated by the dotted line around the button), like the Delete action. So, if i try to delete an executable file that way, the UAC pops up instead. I would have to use Alt-L (in the german version) to proceed. Is that intended?

Which menu are you talking about?

That dialog that comes up, when you push your Delete key. So it's not really a menu, sorry.

grafik

Pushing Enter in that dialog works for me.

It depends. I was also able to delete some text files or JPGs, but what do you see, when you try the same with an exe file? At least for me, something different happens. :thinking:

If you're deleting a file from a protected location like C:\Program Files then a UAC dialog popping up is normal. That dialog comes from the system, we have no control over whether the enter key works on it or not.

Well, it appears not to be a protected location, i have tested drive N. Also, it's not always an UAC popping up, see the screenshot below. Even stranger, it didn't happen with every exe test file i have tried. One of them was deleted straight away. But mostly the installer is getting started.

grafik

grafik

The upper example shows, how the unpack process is started, with no prior UAC.

Edit: i see no issue, if i delete more than one exe file.

Are you pushing Delete and Enter without waiting for the prompt to appear first? That would launch the file you're about to delete.

No. I push Delete, wait until the dialog (or prompt) pops up, then try Enter. If nobody else sees this, i wonder, if something around my Enter key is broken (very unlikely, because it works absolutely normal otherwise), or some weird misconfiguration is responsible. Do you remember my other issue, where i can't browse my collections like i used to, applying Enter twice? Once for opening the image in the viewer, then to go fullscreen. In both scenarious the Enter key is involved, and things are going the wrong way.

I double and multi checked my Enter key assigment in Opus, but nothing suspicious to see there. Tested also another application being turned off, just in case (Hot Keyboard Pro), but no difference. Here's a current screenshot of all hotkeys that use the Enter key. Very strange indeed.

grafik

By default, there is no Enter hotkey:

I tested it with the Enter key removed. Same results with those exe files, plus, i can't go into the full screen mode with the Enter key all deactivated, after i initially open an image window (where Enter works).

But i found now, that using this Enter designation like in the screenshot at least solves the other problem (browsing collections), although not the topic's issue. Seems to happen all around this specific key.

Another strange thing, the deactivated 'Bildanzeiger (Tasten)' entry indicates, that there should be some button in the image viewer, or at least a key combination for it, but there is none (see the second screenshot).

grafik

I found another detail, which i have overlooked at first:

  • The item to be deleted is in light blue (selected state), when i push Delete
  • it turns grey, when the dialog window opens
  • the dialog window changes its look slightly, giving back the focus to the previously grey selected item (gettin light blue again). All that happens within a second.

Sorry, i couldn't screenshoot this one, because my capturing software doesn't support it.

So the delete confirmation dialog is the active window initially, but then focus goes back to the lister behind it?

What's Preferences / File Operations / Progress Indicators / Delay before indicators appear... set to? (By default it's on and 800 ms.) That's the main setting I can think of which might be a factor.

Tools external to Opus that change how windows behave could also be involved. Those tools often get confused by Opus, I think due to the way our threads and window hierarchy works.

Yet another finding: i can delete stuff now like expected, if i very quickly push Delete/Enter after another, tricking that said focus change.

Also checked the setting you have mentioned, it is still on 800ms here. Regarding other apps, i have tried turning off stuff that may have interfered, like CopyQ, Hot Keyboard Pro, my screenshot app, no change. However, the trick i have described, works. Just have to stay under one second. :slightly_smiling_face: