Folder format not populating all columns

I have a slightly odd problem in that some columns don't get populated when I have the Content Folder View for a folder with music.

Columns such as artist, album, year, bit rate, etc doesn't get populated, although the file name, extension, date and 'normal' stuff like that does.
Looking at the same directory with my laptop, I do get all of these columns populated, so I know the fields are there.

I have compared the 'Folder' section of preferences and it is the same between my laptop and desktop.

Is there another setting somewhere that might control this?
I think it used to work at some point, so I am not ruling out that there is a setting somewhere seemingly unrelated I might have changed...

Incidentally, it is the same for both network drives and local drives.

Thanks in advance :smiley:

Is it a permissions issue? Are you able to play those files on the machine that doesn't see the metadata?
Can you view the metadata through the Properties dialog?

Oh yeah, that's not a problem. Both in WinAmp or if I go to properties for the file. It seems a bit peculiar...

And now it's working as intended.
Go figure.

And I didn't even reboot (Although I had done that previously without it fixing anything....)...