Folder Syncronization feature

This feature is extra-cool, btw. :slight_smile: I have a new workflow here at work that's going to have me using this whereas I haven't in the past. I used it for the first time tonight to syncronize some files on my local hard disk to a folder on the destination system's drive over a network.

I noticed a quirk I thought I"d bring up. I'm in the middle of heading out the door and knew I'd forget tomorrow so sorry if this already exists, I noticed the source and destination folders had swapped themselves when it was done with the process. The source was the destination folder and vice-versa. I confirmed that it didn't syncronize this way, it must be a display issue or maybe the syncronize button is activated after it's complete or something. I don't know if this is a common occurence but I noticed it tonight. I can try and give a detail on the steps I took to get it that way if it's necessary, hopefully you can tell just by looking at it where to fix it. :stuck_out_tongue:

Love the software!

Sorry, I meant I don't know if the swap source / destination button was activated, not the syncronization button.

The Source & Destination fields in the Synchronize panel are usually "locked" to follow the source & destination file displays. (You can "unlock" them by clicking padlock icons to the right of the two fields.)

This means that when you change directories in the file displays it is automatically reflected in the Source & Destination fields.

But what it also means is that if you click on the destination file display, which will make it the source, then the Source & Destination fields swap over.

When synchronize two folders (i tested in "one way copy")

If you go to see the properties of the files copied and comparing them with the source file

The creation date and the last access are the same but the date of last modification are added 2 seconds


And if select "Ignores second when comparing by timestamp" in the destination files are considered to be different from those source

But if you do not use this option files are considered equal

But only with these conditions (Always the time of last modification)

source 10:30.58
destination 10:31.00

source 22.36.58
destination 22.37.00


Which filesystems are the source and destination using?

Different filesystems (e.g. NTFS, FAT32, FTP sites, network drives, Zip files) all have different time resolution for different timestamps. Some can only count time in two-second intervals, for example, so times will be rounded up or down when you copy files to them.

The "ignore seconds" option exists to combat this problem.

Source : NTFS

Destination : FAT32

Then to solve the problem just disable the function ""Ignores second when comparing by timestamp".

But I thought that the option should be enabled.

Instead if active I found some files with different timetables

It does sound like the option is acting in reverse, though I bet there's an explanaton for it. Could you make a screenshot or two showing exactly what's going wrong?

First synchronize

Folder A (Source NTFS)


Folder B (Fat32)

After comparing Folder A with the Folder B(screenshoot 1) with "Ignores second when comparing by timestamp" disable

and "No changes detected or required" Appears

After comparing Folder A with the Folder B(screenshoot 2) with "Ignores second when comparing by timestamp" enable

and "copy from source to destination 1 files" Appears

The only thing that I have noticed is that the files have 2 seconds in the time.. and more on the case of this file is a horse with the next minute

source time 9.40.58

source Destination 9.41.00