GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Folder tree/Begining Drive at startup for the day?

Is there a way that I can make my lister start out on a certain drive and expand the tree for that drive to the first level of directories, as in the attached screen shot?

Thanks,
Jim


Jim,

I think all that you need to do is save the current Lister, the one that you showed us, as the Startup Lister Layout.

Under Preferences/Startup/ at the bottom of the selections is on that says "Open a saved lister layout" and select the one that you want.

Hope this helps...

--
Michael Acklin

JimDot wrote: [quote] Is there a way that I can make my lister start out on a certain drive and expand the tree for that drive to the first level of directories, as in the attached screen shot?

Thanks,
Jim

[/quote]

I've already tried that. It doesn't even highlight my drive "C" like I wanted, let alone open it to the 1st tree level.

I've attached another screen shot to show you a pictiue of what gets displayed to me. And, I did make certain that I save my lister before I terminated DOpus & brought it back up again.

Got any other ideas??? I'd really like to make this happen.

Thanks again,
Jim
Dayton, Ohio


resource.dopus.com/viewtopic.php ... xpand+tree

I am stll not having any luck doing what I've decribed in the previous posts.

Any one got any other ideas? I'm stumped!!

Jim

If nudel's method isn't quite what you're looking for you could do it manually. The following button command should open a new lister set to the C:\ drive with the first level folders expanded.

Go C:\ EXPANDTREE NEW

If you don't want it to open a new lister, just remove the word NEW

You could expand upon the idea to launch Opus this way from a Windows shortcut if the shortcut properties are something like:

"C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" /cmd Go C:\ EXPANDTREE NEW

[quote="JimDot"]I am stll not having any luck doing what I've decribed in the previous posts.

Any one got any other ideas? I'm stumped!![/quote]
Jim,

If I understand... try putting this on a button:

Go ROOT=collapse
Go "C:" EXPANDTREE

Thank you for your time in responding to my question.

1st, let me say that I am a newbee to DOpus. I don't know what a "Button" is, how to make one, why I would want to make one, how to use one or anything else about buttons --- LOL!!! :smiley:

I tried John's approach of using the command line in a shortcut for DOpus
with no success. It was as if DOpus was paying no attention to the command line when it started at all.

This whole thing really isn't that big of a deal. It's just one of those little cosmetic things that I'd like to figure out how to do. Know what I mean??? LOL!!!

If you have any other ideas, comments, suggestions,,, I'm all ears.

Thanks for spending your time on this with me & have a great day!!!
Jim

[quote]1st, let me say that I am a newbee to DOpus. I don't know what a "Button" is, how to make one, why I would want to make one, how to use one or anything else about buttons --- LOL!!!
[/quote]

Hi JimDot,
It may help you alot to carefully study Leo Davidson's fabulous tutorial,
Getting to know Directory Opus (tutorial and introduction).
Also see Leo's Toolbars 1 tutorial.

I think John will be much easier to understand after you study the tutorials .

Regards,
Zippo

[quote="JimDot"]Thank you for your time in responding to my question.[/quote]Sure!

[quote]1st, let me say that I am a newbee to DOpus. I don't know what a "Button" is, how to make one, why I would want to make one, how to use one or anything else about buttons --- LOL!!! :smiley: [/quote]I'm referring to a toolbar button. Right click on a toolbar and select "customize". Then right click on the toolbar where you will create the new button and select New=>New Button. Right click on the new button (with the button icon on it). Click "Advanced". In the box that opens, paste the following:

Go ROOT=collapse
Go "C:" EXPANDTREE

You can put whatever text makes sense for you in the "Label" and "Tip" fields. Click on the button icon in the editing dialog to change the icon if you want. That should do it for starters. Click "OK", then "Close" and see if your new button works.

I don't think anyone understood what Jim was saying. I'm getting the same behaviour with the startup folder too. It's because the program is staying resident in memory (the taskbar icon) and not truly 'starting up', so it just opens where it was last.

Jim, you need to uncheck two options:
Go to Settings-->Preferences-->Launching Opus-->Startup and uncheck 'Launch Directory Opus...' and 'Shutdown Directory Opus...'. This should get you what you're looking for.