Folder Tree scrolls too far with wheel if on Windows 7

I believe I may have discovered 2 possible bugs associated with the File Tree.

  1. Vertical scrolling using the mouse wheel in the file tree window offsets the displayed portion of the tree far more than it did in Version 12. Phrased differently, the displayed portion of the window is moving too much per scroll. Each scroll moves the displayed portion of the tree by 40 lines. Scrolling on the File View window or anywhere else as far as I can tell moves the display by only 2 lines.
    Steps to reproduce: Activate the folder tree window, place mouse cursor anywhere on the window, roll the mouse wheel one click, the window moves 40 lines.

  2. Clicking the expand/collapse arrow immediately to the left of a folder in the Folder Tree window causes the current file view to move to that folder as well. This is only the case when you click the arrow of a parent folder to the folder you currently have opened in the File View. It does not happen when you expand a sibling folder or a sibling of a parent. I'm almost certain this was not the behavior in Version 12 (but I couldn't say so with complete certainty). It occurs whether you have the preference "Automatically expand to current folder" selected or not if that is relevant.

Please let me know if there is anything else I could provide to assist. I'm happy to help or try things out, but I don't know ahead of time what would be useful.

Windows 7
Directory Opus 13.1

  1. Can't reproduce. It scrolls 3 lines per wheel notch for me, as per my mouse configuration.

    How many lines do you have set in the mouse configuration?

  2. Do you have the tree lock turned on? There does seem to be a difference between 12 and 13, but only in that particular case.

    What you've described is the normal behavior, but it looks like the lock would override it in 12 and doesn't in 13. What 12 did probably makes more sense, so we can change 13 to do the same when locked.

Thanks a lot for the quick reply, I appreciate it that you took the time to entertain it.

Regarding the second one about clicking the arrows next to tree branches, I was mistaken and you were right. I have two installations, one running V12 and one running V13 and tree lock was activated on the V12 when I compared.

Regarding the first one about scrolling on the tree, I'm not sure how I could help solve this or if you have any other thoughts, but let me provide a little more information.

  1. My mouse wheel is set to move 3 lines in the mouse configuration
  2. Scrolling with the mouse wheel over the File Display scrolls 3 lines as expected.
  3. Scrolling over the list of preferences in the Preferences window scrolls 3 lines.
  4. Scrolling over the Folder Tree scrolls 40 lines (exactly 40 if that is of any use).
  5. The scrolling issue was present even after I completely reset the configuration of DirOp to the defaults through the Backup and Restore window.
  6. Scrolling behaves as described above for two different wireless mouses I tried.
  7. There are no scrolling issues with any other programs I have installed as far as I can tell.
  8. The same behavior occurs over both file trees when dual display is open and set to display separate trees.
  9. Scrolling with my track pad scrolls 1 line at a time (though I doubt this is useful).
  10. It was definitely not like this before I updated to V13.

I'd be happy to provide any more information that you think might be useful in helping you reproduce this or maybe give you an idea about what might be happening. If images or videos or screencaptures or anything would be of use, I can provide.

Thanks again

Just a suggestion uninstall version 12 then try again.

Second suggestion use a screen recorder so that the developer can see exactly what you are doing.

Thirdly it could be another software causing the fault why not use winaudit (you can find it doing a google search) to show what is on your system, to the developer. Winaudit lists all software and drivers on your computer.

Got any AHK scripts or similar that might be changing what the mouse wheel does depending on the window/class it's over?

I could see someone using something like that to work around badly written programs that don't scroll the correct amount (e.g. Task Manager's main tab only scrolls 0.5 lines instead of 3 per wheel notch). If so, it might be triggering for the folder tree in Opus as well by mistake.

Thanks for the suggestions. I wasn't clear, I have version 12 installed on a second machine, so uninstalling it definitely won't make a difference.

I did try uninstalling and reinstalling V13 and the same odd behavior is still present.

I also tried running winaudit, but I really have no idea what in that long list of information it generated is useful. I'll ask the developed if he'd like to see it.

Thanks again.

Thanks again for the help. I do not have any AHK scripts running as far as I can tell. I do use a program called xmouse which directly affects scrolling (by allowing the window the cursor is hovering over to scroll without being active) but I uninstalled it while testing.

Since my last message, I tried uninstalling V13 and reinstalling. The same behavior was present. Then I tried uninstalling V13 and reinstalling V12 and scrolling on the file tree worked fine. Then I uninstalled V12 and reinstalled V13 and the scrolling issue came back.

If you have any other ideas that you'd like me to try, I'd be happy to. Believe it or not, the ridiculous scrolling isn't proving to be that big of a deal. It's actually pretty useful to be able to get to the top instantly. Having said that, it really seems that something must be different between V12 and V13 and whatever that is might have introduced some unintended behavior in this area. It's odd that it seems to only be affecting me though...

I ran winaudit per Splash3313's suggestion above and would be happy to share with you the html output file if you think that monstrous 1.4MB pile of text might be useful.

Also, this is probably unrelated but maybe not, I noticed another possible small bug when I was restoring my configuration after the several installs/uninstalls. It seems that the preference information under Folder Tree > Contents is not correctly being applied when restoring. I included an image of the state of DirOp immediately after I used the system restore. You can see in that image that the appropriate folders are shown in the preferences (those are consistent with the configuration that should be reflected in the restore file I used), but not in the actual Folder Tree. You can see that "Apply" is disabled indicating that I did not make any changes. When I pressed "OK", the Folder Tree was immediately updated to correctly reflect the prefereces. DirOp also did not remember the folders I had pinned open in the Folder Tree, but I'm not sure if it was supposed to or not.

Thanks again for your effort and care.

Just upgraded to 13 and I have the same problem #1 that G-Cam mentioned. Only Win10 mouse drivers with Logitech mouse and the issue only pertains to the directory tree. Let me know if I can provide any info to help debug the issue.

Just a thought what mouse settings are you using in windows could be related to that.

I also wanted top report that I have the scrolling issue with the mouse wheel in tree view since updating to v13.
This is a very annoying issue, I tried changing various settings settings, but nothing helps. Also closing all tray software and disabling antivirus.
I noticed some large spacing in the tree view between items, perhaps this is part of the issue?
OS windows7 64 bit (yes I know that I need an upgrade to a never OS :slight_smile: )
Screenshot_1

Is anyone seeing this issue who isn’t on Windows 7? That seems the common factor so far.

I haven't had any issues with two computers running Windows 11 with a logitech mx master 3 and mx anywhere 3 and logitech option driver is not installed, only uses the default Windows 11 driver.

Not seeing it with Windows 11 Pro

Small update.

I changed my mouse settings line jump from 3 to 1, which decreases the scroll jump. it's still to much for my taste. But I counted it, when the line count is 1 it takes me 3 notches of the mouse wheel to scroll the same distance in the three then with lines set to 3 with one notch of the wheel.
Screenshot_2
.
Of course I can't leave it like that as it makes scrolling in all other applications very slow

One extra bit of information if it is useful. Going off rocker_lx and Splash3313's suggestions, I tried counting the scroll with different mouse vertical scrolling amounts. It turns out that the tree scrolls exactly 20 times as many lines as included in the mouse properties. So if you have is set to scroll 1 line, the tree scrolls 20 lines. 5 has is scroll 100 lines.

I don't know if that is useful but it surprised me that it was so perfect.

My Logitech mouse with Logitech driver scrolls correctly under Win11 Pro.

Try a different mouse to see if it is not the mouse you are using is incompatible with Directory Opus. Also please list mouse you are using and what version of mouse drivers you are using and version of Windows 10/11 you are on. Reason I say this is that if the developers can not reproduce this then it is most likely something on your computer causing the fault.

Windows 7 Home Premium 64-bit
Mouse is Microsoft Sculpt Model 1596 driver version 6.1.7600.16385

I do not have another mouse but if the opportunity to try one comes up, I will do so and report back.

I'd be happy to provide as much information as I can and test anything you'd like. I'm not incompetent with computers and could probably do moderately advanced diagnostics if useful. Though, if I had to make a suggestion, I would suggest starting with the facts that:

  1. This did not happen when I had V12 and when I reverted back to V12, the File Tree scrolled normally. So something about V13 is different in that area and causing the scrolling issue.
  2. It only happens in the File Tree. All other scrollable areas in Directory Opus are unaffected.

I wouldn't presume to know what I'm talking about but it really seems to me that this issue has to be directly related to a change made in how the File Tree window responds to wheel events and it is likely a change that only affects Windows 7 (though we really don't have enough information to confirm that, but it seems likely at this point). It really seems unlikely to me that the behavior is more than coincideltally related to my machine or its configuration specifically. Why would only the File Tree be affected and not the File Viewers or the Preference menu, or the Viewer Pane (it's difficult to tell how much this is scrolling but it doesn't seem unreasonable), or the Metadata pane? There must be something different about how wheel events are handled and investigating that seems to me to most fruitful path forward.

Thanks

Opus 13 uses the tree control in a different way to 12, in order to achieve variable size rows. I suspect this might be causing the problem on Windows 7 (i.e. I suspect it's a bug in the Windows tree control on that OS, but triggered by Opus using it in a different way). We'll look into it further and see if there's a way around it - failing that we can always add an option to disable the variable row size mode.

1 Like

We've found the reason the tree scrolls too far in Windows 7 (and Windows 8) and have a fix coming in 13.2.1.

Other OS won't be affected by the problem. (I've edited the thread subject to help people with the same issue find it.)

3 Likes