Folder Tree Slow to Show Folders

The tree should already load folders in the background when it first launches, but something else may be causing the blockage. It is not normal for reading a folder to take long, unless something is unresponsive.

e.g. Unavailable network drive mappings can cause a lot of problems throughout Windows. Similarly, mechanica drives which have gone to sleep can cause a delay if they need to spin-up. Opus aims to minimise the impact of that kind of thing, but sometimes something depends on accessing the data and everything then has to wait. Antivirus can also cause blockages across the whole program even when using multiple threads, and sometimes disabling it doesn't remove its effects (but it depends on the a/v program).

Can you narrow things down to a particular folder?

Do you see things take a similar amount of time in Explorer or other programs?

Is the slowness only the first time any program lists the folder(s)? Is it then fast in just that program, or does one program accessing the folders make them accessible quickly in all other programs from that point on?

Is it only just after system boot?

Using Process Monitor to see what is being accessed and generate a .PML log file of the operations can be a good way to show exactly where the delay is coming from. That can reveal both the device/folder/file which is slow and the code (in Opus) or 3rd part component (external to Opus) that is causing it to be accessed.

Any folder with a significant number of subfolders appears to be affected. I have an i7-6900K processor, 32GB memory, and running on a 1TB SSD drive, so computer speed does not appear to be the reason.

Also, I notice that when I open File Explorer, it does NOT exibit this behavior of slow loading of subdirectories. Once the initial subdirectory load has been accomplished, return to this directory will result in loading the subdirectories quickly. It appears that after they have been loaded once, subsequent loads are okay.

However, it has been my practrice to close the program and not just minimize it when not using it. Each time I restart the program the slow loading of subdirectors is again noticed.

Disabling TrendMicro anti-virus does not speed up the loading of folders.

Was if fast in Explorer because the folders had already been loaded recently in something else? The filesystem caches that kind of information and one program loading the folders can speed up another that loads them afterwards.

Have you tried turning off zip files in the folder tree? That can slow things down (usually due to antivirus, particularly the one built in to Windows which may be enabled).

Several questions/suggestions in my previous reply are still unanswered.

Explorer always loads fast, even if just after a restart. Dopus is always loading slowly, the bigger the folder contents, the longer it takes.

Zip is OFF in folder tree. FTP is OFF. Disabling anti-virus results in no improvement. MSE not running. Network drives not included in display.

Tried running .PML log but there is a log of information there, and not sure how best to filter it to reveal the pertinent items.

If you zip and send the PML log to us, we can look at it for you.

Can you suggest any filters I should apply to the .PML log to focus on the most important entries? For example, should they be the entries generated and logged as related to dopus.exe? Or is it important to include others?

Please include everything. We can filter the results after loading the log, if needed. If they are filtered before saving them we may miss useful information. That can include what other processes are doing at the same time.

I starting Dopus, and then selecting 2 subdirectors that had large numbers of subfolders and files.

It takes about 7-8 sec for each of the subfolders to display after being selected.

The .PML log that was generated is here:

I'm getting "internal server error" from that URL.

what is a "PML log" ?


(lchanged hosting companies)

It looks like every time a folder is inspected for the tree, a lot of extra work is being done by a combination of shell extensions and other hooks installed by:

  • Acronis True Image
  • Adobe Core Sync
  • Trend Micro Antivirus

Additionally, every time a DLL or EXE is opened there is quite a long delay, which may indicate virus scanning is having a significant impact. It looks like both Trend Micro Antivirus and Malwarebytes are installed on the system and scanning at once, so it may be one or both of those causing or increasing the delays.

I would try uninstalling Trend first as a test to see if it is involved, as it seems to be doing more than the others, but it's hard to tell for sure from the logs. Note that disabling antivirus does not always remove their effects entirely, so it may be worth a quick try but if it doesn't make a difference then an uninstall + reboot is still worth trying in addition. Of course, once the test is done you can reinstall it and should be back to normal.

I've been having the same problem for a few years now and I have tried EVERYTHING and nothing worked... EVERY suggestion in this forum and other forums didn't work... I searched high and low... disabled everything using shexview, used so many other tools... uninstalled all antivirus and firewalls, etc... I had two computers with the same problem, one with Windows 7 and the other with Windows 10.

The curious thing was that only Directory Opus seemed to be affected. Windows Explorer, Total Commander, and Speed Commander (yes, I have a few other file manager that I collected over the years, up until I found Directory Opus) were totally unaffected... go figure.

Anyhow, no matter what, Directory Opus always displayed/populated the directory tree way way too slow... I even went back and installed version 9 from back in the days that I remember it worked lightning fast... nope, didn't work. Then, if the problem persisted even when installing the older version which I remember was almost instantaneous at showing the folder tree, then the problem had to be with the OS... so, just by good karma (and an ounce of mischief), I uninstalled a program I no longer needed (Impulse Icons Manager) and it left me with all my desktop (and everywhere else) icons as white pages... there are other programs that produce the same problem when uninstalling, but this one was very connected to the icons. Anyhow, the icon Registry Key handler in Windows was left damage and when applying the fix below, it also fixed the Directory Opus problem (by the way, in another computer where I didn't have Impulse, Directory Opus still had the same problem and after applying this fix it also went back to normal, to populating the directory tree instantaneously - therefore, at least in my case, the problem was the Icon Handler registry key).

This is what fixed it for me:

  1. Open REGEDIT and go to the following key:


  1. Inside that folder "Shellex" (it's actually a key, but it looks like a yellow container folder), delete the whole folder or container called "IconHandler". This will also delete everything inside that container.

  2. Reboot the computer. Voila! Done. DirectoryOpus love at first sight all over again!!!

I hope this fixes it for you too.

1 Like

We have been having this issue too, for perhaps 6 months, with three installations of DOpus12. Just looked at Regedit and we don't have an "IconHandler" folder/key within HKEY_CLASSES_ROOT\exefile\shellex. so can't follow the above fix.

Doesn't happen with Windows Explorer, doesn't happen with ACDSee Image Manager. We mostly access a NAS which is fast and generally responds as quickly as a local drive. Clicking on a folder in the folder tree instantly shows the contents of that folder in the viewing pane, but clicking on the + or > in path of the folder tree takes seconds to open the folder in the tree, whereas it used to be instant. This makes my preferred method of navigation - along the path of the folder tree - seem slow enough to look for alternative less efficient methods.

Any other suggestions?

A process monitor log of what happens when you expand the folder might reveal something. If you send us a log, please let us know which folder path was expanded so we know what to look for.

I have seven more suggestions. PROCEED AT YOUR OWN RISK. I mean it.

One of my computers at home was experiencing exactly what is happening to yours (NAS and everything). The previous solution already posted fixed it though.

I am pretty confident in saying that you are having a problem with the icons or icon handler or icon cache.

There are several other things that I have tried at work to fix the Directory Opus issue. You see, I carry in one of my USB Flash Drives a portable version of Directory Opus.

Some computers at work were behaving similarly like you describe even when using the portable Dopus. These computers also didn’t have the “Shellex” container, so I had to search elsewhere, for other solutions. One solution worked with some computers, another solution with others. Besides what I already posted as a solution, here are the other ones which fixed it for me at work with different computers. The steps and code below are totally accurate, simply copy/paste and use it. All the following solutions were found in different forums all over the net over the years. I have tried them and they all work, I mean, the solution does its job… but if one solution does not work in a particular computer, then try the next solution… and so on.
First thing first... (this is one of the seven suggestions)

  1. Open a command prompt with administrator rights and paste the following command, and then press ENTER:

    fsutil dirty set c:
  2. Reboot the computer and CHKDSK will perform a drive/folder/file structure scan and fix any errors.

Then, and only then, the hunt begins...
Refreshing the Icon Cache Quickly

  1. Press WinKey + R to bring up the Run dialog. Then, run the following command and hit ENTER:

    ie4uinit.exe -ClearIconCache
  2. Reboot the computer.

See if this fixed the Dopus issue.
Delete the Icon Cache. v.1

  1. First, open Notepad and paste the below code:

    @echo off
    taskkill /F /IM explorer.exe
    cd /d %UserProfile%\AppData\Local
    attrib –h IconCache.db
    del IconCache.db
    start explorer
  2. Save the file as a ResetIcons.bat file on your desktop (or any filename, as long as the extension is .bat)

  3. Then open explorer and navigate to C:\users\username\appdata\local (make sure you've selected to view hidden folders, if using Windows Explorer) and delete IconCache.db.

  4. Lastly, double click on the “.bat” file that you just saved on your desktop.

  5. Reboot the computer.

Check and see if Dopus is working fine now.
Delete the icon cache. v.2

  1. Open a command prompt with admin rights.

  2. Copy and paste each command line below, one at a time into the command prompt, and press Enter after each command. The last command will instantly reboot your computer.

    ie4uinit.exe -show
    taskkill /IM explorer.exe /F
    DEL /A /Q "%localappdata%\IconCache.db"
    DEL /A /F /Q "%localappdata%\Microsoft\Windows\Explorer\iconcache*"
    shutdown /r /f /t 00

Deeper level of rebuilding the icon’s cache.

  1. Open Notepad and paste the following code:

    @echo off
    set iconcache=%localappdata%\IconCache.db
    echo The Explorer process must be killed to delete the Icon DB. 
    echo Please SAVE ALL OPEN WORK before continuing.
    If exist "%iconcache%" goto delID
    echo Icon DB has already been deleted. 
    exit /B
    echo Attempting to delete Icon DB...
    ie4uinit.exe -ClearIconCache
    taskkill /IM explorer.exe /F 
    del "%iconcache%" /A
    echo Icon DB has been successfully deleted. Please "restart your PC" now to rebuild your icon cache.
    start explorer.exe
    exit /B
  2. Save the file as RebuildIconsCache.bat (or any file name, as long at the extension is ".bat")

  3. Run this file by double clicking it and then immediately reboot the computer.

Check and see if Dopus works fine now.
Reset all icon’s registry settings with a registry key file.

  1. Open Notepad again and paste the following data:

    Windows Registry Editor Version 5.00
    "Content Type"="image/x-icon"
  2. Save the file as icons.reg (the file extension is now ".reg")

  3. Double click on the registry file you just made and click on "yes" or "ok" when prompted to confirm that you want to merge this data into your computer's registry.

  4. Reboot the computer.

Check Dopus.
I found the following suggestion at a Stardock forum which also worked.

  1. Believe it or not, go ahead and install Stardockk IconPackager through Impulse. In other words, download impulse (is a Stardock software manager) and through that software install the IconPacager. Restart your computer. NOTE: if Impulse is not available or it will not install easily, then you can try installing IconPackager directly by downloading it here: (

  2. Once the IconPackager is installed, go ahead and download this FIX provided by Stardock themselves:

  3. Run the utility odnt_zapper.exe

  4. Check/select the option "IconPackager" and click "Apply"

  5. You may get 2 warnings. The first will be a "cleanup" warning asking if you are sure you want to delete everything. Select YES and ignore it. After you select yes, you will receive an error saying you must re-install. Ignore this error and select OK. Then, click on OK in the last window and exit the program.

  6. Reboot the computer.

See if Dopus now works properly.
Remove Custom Default App Associations

  1. Open a command prompt as administrator

  2. Copy/paste the command below into the command prompt and press Enter.

    Dism.exe /Online /Remove-DefaultAppAssociations
  3. Reboot the computer.

Check Dopus and hopefully this one solution worked.
If none of this helps, then either format the hard drive and reinstall windows (and install one by one all your application but Directory Opus fist, and test Dopus after installing any other application to see which one messes it up), or buy a new computer. Just kidding. One of these will work.

I was forgetting one more option.


You may also be having a registry problem, in general. If so, download and run a registry cleaner (is best never to do this, but in some extreme cases this is the only solution).

The one I have tried (and I have tried many) and it has been very safe (no damages so far in any of the computers that I used it) is Wise Registry Cleaner (

If you find a solution, please come back here and let us know what worked.

Luis, thanks for that extensive list of scary procedures :open_mouth:

I will start with Leo's process monitor log and see what he has to say following that, but your suggestions look very helpful, thank you.

@BillB Thanks for sending the log. It looks like your issue is being caused by the Dropbox shell extension taking a long time when icons are requested.

Could you try disabling the shell extension to see if the problem goes away? That would confirm the cause. Here's how:

Leo, thanks, that solved it. I guess a Dropbox update might re-instate those shell handlers, but at least we will know where to look and what to do.

Thank you for identifying the problem. To everyone else, these were the steps that solved our problem caused by Dropbox:
• run shexview.exe (click Yes when it requests permission)
• Wait for the list to populate.
• Sort by the Type column and scroll down to the Icon Overlay Handler entries.
• Select the DropBox extension(s) then right-click and select the option to disable them.
• Don't do anything else! You are editing the Windows Registry.
• Close shexview.exe
• Reboot.

I think that this removes some specific Dropbox icons, like the ones showing folders syncing, but these are not really required as Dropbox mostly just works in the background. It still runs fine.

DOpus should be back to being responsive.

1 Like