Folders opened in new lister, not a new tab

I think my file/folder associations may be bugged. I am unsure of where to start to fix the issue.

Regardless of the setting in Preferences - Launching Opus - Explorer Replacement, it always opens a new lister for any folder that is opened externally.

RAR, 7z and other archive associations are also broken.

I think this has been a recurring issue because I recently reinstalled Windows, and I always seem to have trouble whenever I restore my configuration for Directory Opus.

This error occurs in one program where it simply did not open a folder at all:
ShellExecute 'v:/PC Games/ModOrganizer2/logs' failed (error 2).

I am on Directory Opus 12.25 and Windows 10 21H2.

Opus doesn't take over .RAR or .7Z itself (outside of Opus, I mean; double-clicks inside Opus will usually open those formats within Opus), so those may have been assigned to Opus using the Open With > Choose Default Program menu. If so, assigning them to something else via the same menu should work.

For folders, choosing "Don't Replace Explorer" should stop Opus handling folders that other programs open. If that doesn't work, try this:

If that also doesn't work, please go to Settings > File Types in Opus, then File > Diagnostic at the top of that window, and save a diagnostic for Folders: (86.1 KB)

My issue is opening a folder from another program always opens in a New Lister and not a New tab like I want it to.

I've attached the diagnostic.

I understand now. I've edited the thread subject to clarify things.

The registry settings look correct to me. The only thing I can see that's wrong is that the Apply button hasn't been pushed in the Preferences screenshot, but presumably you've tried that already.

If you go to C:\Program Files\GPSoftware\Directory Opus and turn on the Description column, what are the version numbers for dopus.exe and dopusrt.exe there?

Yes I have tried that.

dopus.exe and dopusrt.exe are both

Might be worth trying 12.26 that came out today, as that's what I tested with myself when I checked it was working OK here:

Although I don't think we made any changes in this area in the update.

1 Like

Just saw your DM and checked with your config and it worked OK here, which should rule out any configuration setting being the cause.

In case it makes a difference, I've been testing with folders created on the Windows desktop which I'm double-clicking.

Typing a folder path into the Start Menu (or Win+R Run dialog) is another way to test things (and worth a try if you're using Fences or anything similar, just to rule that out).

Odd. It seems that it is indeed fixed after I updated to 12.26.

Thank you for your help.

1 Like