GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Folders slow to open first time


#1

Upon first starting Dopus, after clicking the plus sign on a folder, it takes 3-5 seconds before it expands to show the folders at the next level. This delay does not occur subsequently, that is, after closing the folder and opening it again. Any ideas on how to fix this very frustrating behavior. I have tried all of the options on a FAQ.
Thanks


#2

Does Explorer do the same thing?

For all folders or just some?

It could be the HDD spinning down when not in use (and the folder information being cached afterwards), or anti-virus software scanning the folder contents when Opus accesses them (e.g. to populate the Description column or similar columns you may have switched on which display information about file contents).

Got any network drives mapped to unavailable machines?


#3

Explorer does not do this. It happens on all folders. I do not have any network drives mapped. Like I said, once a folder has been opened/expanded during a Dopus session, it does not happen again with that folder.


#4

I do use folder icons, with the "Change Folder Icons" program. Could that be the cause? Why would it affect only Dopus and not Explorer or PowerDesk?


#5

P.S., Besides, it also happens with folders for which I have not assigned an icon!


#6

It could be the cause, yes. Try disabling that program. Maybe its icon handler (which will be called whether or not the icon is overridden, since you have to ask if it's overridden to know!) doesn't like the way Opus call it for some reason.

It could be innocent, and something else be the cause, too, but that's definitely worth ruling in/out.


#7

I can't find how to diable the program without having to then reset all of the icons again later - any ideas?


#8

Use ShellExView to see if it has installed some kind of shell extension which you can temporarily disable.


#9

OK, I've used ShellExView, diabled Icon Handlers (X1 had one in red), Context Menus, and System Shell Extensions in turn, rebooting each time, with no effect. Anything else I should try disabling?


#10

I'd try disabling any non-Microsoft shell extensions. Also any viewer plugins in Opus.

You shouldn't need to reboot, just restart Opus after disabling stuff. (You probably don't even have to restart Opus, but might as well just in case.)


#11

Alright, I discovered that it was Mozy related. I had seen a previous post or FAQ about Mozy and thought I had made the appropriate change. However, I found that I had not checked "Disable icon overlays in Windows Explorer" Once I did that, Opus works fast as it should again!

Thanks a million for your help Leo.


#12

Thanks for reporting back. Shame that issue still exists between Mozy & Opus but it's useful to know it's still a problem in case other people run into the same thing.