FTP cache and file copying-duplicates in an empty directory!

A weird problem that I've now solved by setting to true the ftp_do_not_cache.

I was getting all sorts of copying errors (file exists, failed to replace, etc) on what was essentially an empty directory at my hosting site.

I was trying to overwrite all the files from a Joomla install that went wrong (all the CHMOD permissions got screwed) but no matter how many times I deleted the files and directories on the server I just kept getting dopus ftp errors about the existence of files that didn't exist. It wasn't all of the files but the same ones each time I tried.

I got the hosting site to reset everything but it made no difference, still the ftp copying errors. At last I tried the ftp_do_not_cache option in Preferences-Miscellaneous-Advanced and now it all works just fine, all the files are copying over without and errors.

Why has this been happening, does it happen to others? If this kind of problem can happen with a cache I can't see any possible use for it!

Win XP SP3, latest Dopus, Avira Premium

Looks like nobody here at the forum has any advice about this. Please report it to GPSoftware if you haven't already.

(It's not normal, BTW. I've never had to turn off the caching. The cache can get confused if things change at the other end but simply disconnecting and reconnecting should solve that problem, if hitting F5 to refresh doesn't. The cache can store info about sub-directories which F5/refresh won't affect, remember. The cache doesn't persist across sessions.)

Thanks for your reply Leo

The problem happened over quite a few hours, even through a spell of doing nothing overnight, but I don't think I actually terminated the session manually but doesn't the session time out anyway after a period of inactivity?

Would that not clear the cache?

How does one actually disconnect and reconnect the FTP session? Is it by navigating away or closing the lister and then logging in again?


I think the cache will persist as long as the session is open.

(I'm not sure if it's literally the FTP session or if it's the window being open. The cache may persist across sessions that timeout and are re-established automatically for a given window. Opus may also be configured to send "keep alives" to prevent the session from disconnecting when idle.)

I doubt that the caching system is designed for usage where the same FTP window/session is kept open for many hours/days. Perhaps the cache should expire after a certain time; that'd be worth suggesting to GPSoft if it's causing problems.

Yes, exactly.

If in doubt, check the FTP log via Tools -> Output Window. It will say when the session has been disconnected. (Note that there can be multiple sessions to the same site, e.g. if you navigate around the site while a file is downloading from it.)