FTP connect issue

I'm evaluating and enjoying very much.
Issue with FTP tho.
"An error occured when reading folder: connect() WSAENETUNREACH: Network is unreachable

... What the..??!

Thanks for any help!
Roger Wiese

It means what is says:) It means that the windows socket that your connection is using has dropped out.

The Port (21) that I'm using is the same one I use with 2 other FTP access programs I use on the same PC. I have never had this issue with those, so I figured it must be something to do with Opus.
I try, for example Core FTP immediately before & after with no problems.

... and my efforts to find the answers in Google haven't produced much joy.

So ... if someone else has any clues why this would happening in Opus but not elsewhere, I'd would appreicate it.
Thx

File a formal anomaly report (Support page of GPSoft web site) with details of the site etc and then I may be able to get time to run a debug session for you to see exactly what is happening.

fairport01,

Have you tried everything in the FAQ: I can't get FTP to work?

In particular, the first suggestion regarding PASV mode, which is usually the solution if everything works up to the point where the directory is read.

Hi,

The FTP just quit on me after working just fine...

I now get the following message:
"an error occurred reading folder:
Invalid Server name or address: ftp32.bravehost.com"

This ftp address is correct and works with other ftp programs.
Can you please tell me how to fix this problem?
Thanks!

Samito

PS: I'm using Opus 9

Perhaps the server is down?

[i]Pinging ftp32.bravehost.com [65.39.211.44] with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.[/i]

If not, go through the FAQ I linked in my reply above and let us know what further information you can find, particularly in the log window.

Hi Nudel,

Thanks for your answer.
I've already been through your list, I use all the defaults options of Opus. I also turned off my firewall (Kaspersky) to make sure it was not blocking the connection.

Here's the message I get in the Output Window:
Invalid Server name or address: ftp32.bravehost.com

I also tried with and without the passive mode (PASV), no change.
I've also enable the FTP log, it doesn't show anything.

Could my configuration files get corrupted? How does one remove them totally??

Thanks for your help,

Samito

Do you have a space at the end of this string name, such as

"ftp32.bravehost.com " ?

Remove the space.

Greg, you're a genius!!! It didn't show any space, so I remove the last letter, retyped it and it works!
Thanks!!!!
Samito

2 Likes

Interesting that in some 6 years no one has ever reported this problem before!

It's an anomaly in the code that we'll fix in the next version.

Does that mean I qualify for the next version? :wink:
Samito :smiley:

All registered users qualify for the next update version!

I wonder if this bug was ever fixed..? This just happened to me right now. I pasted my FTP credentials over and over.. I know I had the right ones since I had just successfully done the same thing in another FTP client (WinSCP). Drove me nuts..:smile: After reading this thread I deleted some invisible characters at the end of the username field and vo├Čla.. working like charm. PS. thanks for a wonderful program DS.

Which version of Opus?

Which dialog are we talking about, and which field within the dialog?

The thread is very old so I don't have any memory of exactly what was done afterwards, but it sounds like it was to do with the FTP address field, but not any others.

If we're talking about the username or password fields, it's possible that spaces at the ends of strings need to be kept in those, since they may be part of the username or password on some systems/setups. (OTOH, you cannot have a space at the end of an IP address, so it makes sense to trim that field.)

Hi thanks for responding. It's latest version 12.6 (pro x64).

Yes it was the FTP connection details dialog > username field (and maybe the Host address field too.. I think I deleted and rewrote the last letter there as well).

I think I backspaced two or three times at the end of the line without the cursor moving before the last letter was deleted. (Hope this makes sense..).

(Yes I noticed that this thread was very old, nevertheless it effectively solved my problem :slight_smile: )

I have the same issue
Dopus 12.10
FTP connexion with FileZilla : OK
Exact same settings in Dopus : KO
Retyping the host name, and trying all kinds of different options always result in "Invalid server name or address"
I am at home (no proxy)
Advice is appreciated

Please link your account and try with the lastest version of Opus 12 first.

Hi,

Account linked and upgraded to 12.11 :slight_smile:

Things are a bit different but still not successful.

When trying to connect after a few seconds I see:
Opening Connection xxxx.xxxxx.xxx:22
"FD_CONNECT - WSAETIMEDOUT: Connection timed out"
Cannot connect to Site

Any ideas ?
Thanks in advance

Unless the site takes a long time to connect (or the timeout has been set very short), it probably means firewall or antivirus software is blocking Opus from connecting to the site, if identical setting work in FileZilla.